OSMC on RPI3, IPTV stream not being deinterlaced

Hi,

Apologies that I probably don’t have enough support info in here, but I’m quite new to this.

I have OSMC on a RPI3 running an IPTV stream using the standard player. I have variable refresh rate turned on so that KODI can change it depending on the video that’s being played.

I’m trying to watch (what I believe should be a ) 1080i stream. The issue is that this doesn’t seem to be picked up as an interlaced source by OSMC, and it does something weird where it say’s it’s actually a 720p (see image 1).

I’ve tried flipping between different interlace modes, but it doesn’t make a difference. Can anyone point me in the correct direction?

Image 2 shows the interlace artifacts in Kodi (the phone camera actually cleans it up a bit, it’s way worse in real life).

Image 1: https://i.ibb.co/7Y1PV1J/IMG-20191115-192102.jpg
Image 2: https://i.ibb.co/T4js4gQ/image.png

First off you’ll need to provide some proper osmc logs for anyone to correctly identify what the problem is.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Wow! I’m actually impressed with how simple uploading logs is these days.
To create this log, I enabled logs, than rebooted the device and straight away loaded the offending stream.
Cheers for the reply gb160

https://paste.osmc.tv/hulamewava

EDIT: I realise there’s some stuff in here that shouldn’t be there, I’m going to change it since I already showed the link before realising anyway.

It’s been like that for a few years :slight_smile:

Unfortunately it’s not clear why the stream is not being deinterlaced.
ffmpeg doesn’t seem to believe that the stream is interlaced however.

I can play the exact same stream in VLC and it detects it as 1080 25fps, which I assume is as it’s correctly picking up the interlacing. The steam looks fine.

It certainly seems to be an issue with how ffmpeg is detecting the stream.

Has anyone any ideas? Can I change some settings in ffmpeg to try and get it to detect the stream correctly?

No - perhaps the next ffmpeg bump should fix things

Sam

Is that anytime soon, or is there a beta channel or something I can try?

EDIT: or is it worth looking into this with ffmpeg directly?

Not at this time

Sam

Something crazy just happened. I put on a stream and it was perfect!! Deinterlacing was working perfectly.
There was a glitch in the stream, it reloaded, and now the deinterlacing has stopped working again :confused:

For some reason I can’t get the video info screen to pop up, so I wasn’t able to see if it was correctly detecting the stream as interlaced.