OSMC on RPi3B+ how to change keyboard layout?

I just installed OSMC from the image on the OSMC website on a brand new RPi3B+.
In order to connect with SSH using PuTTY I had to replace my old PuTTY installation with the most recent because PuTTY and OSMC could not agree on “key exchange algorithm”.
Then I could connect.
But now my command line is very difficult since the special characters are not on the same keys as my keyboard apparently.
I want to use English as my system language but a Swedish keyboard layout both when interfacing via the main GUI and via SSH.
How can I change to Swedish layout while keeping the system language as English?

I have used the KODI GUI to change keyboard in system settings but even though I restart OSMC the key mapping in PuTTY SSH connection seems to always be English…

Do you mean System->Input->Keyboard layouts? That should work.

Sounds like client side, if putty layout is english. I have swedish keyboard layout, but no åäö (server side) in putty.

It is not a client side thing, PuTTY behaves differently towards different RPi and Ubuntu machines when I connect.
The new OSMC is set to Swedish keyboard in the GUI settings dialog and it works as long as one uses the KODI screen. But when I connect via SSH using the latest PuTTY program, the ÅÄÖ characters special to Swedish do not show up when typed. For one of them a dong sound is returned for å and ä but the ö char results in a new line containing text:
(arg: 6)

Not so on my Ubuntu machine or a regular RPi2 running Raspbian.
But these were set up with Language = English and Keyboard = Swedish and this is what I am asking how to do on OSMC (terminal commands).
Same PuTTY in all cases…

in shell:

sudo dpkg-reconfigure keyboard-configuration
Logotype (right)

sudo dpkg-reconfigure locales
chose sv_SE.ISO-8859-1
I chose system wide

in putty, under windows->translation choose: ISO-8859-1(Latin-1, West Europe)

should give you åäö in console and system in swedish (dialogs etc)

1 Like

I had to first start with:
sudo apt-get install keyboard-configuration

I now have åäö after logging out and back in again.