Osmc on the Vero 4k+ vs Raspberry Pi 4b (4GB)

I have been A/B testing video playback on my new Vero 4K+ against the March 2022 build of osmc on a Raspberry pi 4b with 4gb of RAM. Approximately one third of my library will not play at all on the Vero but will on the Pi. For reference, my setup is both Vero and Pi are connected to the same lan and switch, both connected to an LG C1 4K tv on two different hdmi ports. Both are being fed video over the lan from an openmediavault server, with a 5 drive hardware raid array totalling 48TB ( so 5 12TB drives in a raid 5. Both devices are connected with the same brand hdmi and ethernet (Cat6) cables. The files that the Vero will not play range from 70mb .mkv files to 26GB mkv files. Some are tv episodes and some are movies. all using a variety of encoding algorithms.
What I cannot figure out is why the pi running osmc will play any and every file but the Vero balks at so many, often just playing sound with a static screen or simply not at all.
Is there some sort of additional setup I need to do with the Vero?
I can provide a group of files that play on the pi but not the vero in a Google Drive share if that would help.
Thank you.

I would assume there might be a pattern of old encoding algorithms that the Vero doesn’t support in hardware and that might be struggling in software decoding.

Generally out of the box should work, but follow the below steps to share your logs for the team to figure out what’s going on.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Please provide some logs as suggested previously