OSMC on Vero 4k almost unusable after recent update

OSMC has been very reliable until the recent update. Now it is incredibly slow most of the time and just doesn’t respond at all sometimes.

If I’m using BBC iPlayer it is okay most of the time. Never fast but okay. It no longer remembers the programmes I am watching but it is just usable.

When I try to play a file on my NAS it no longer responds. I can play the file but I cannot stop it, rewind, fast forward or anything. It was not like this before the update.

I am using an IR remote control.

First advice provide debug enabled logs


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Is the playback slow or just the remote?

Have you tried changing the battery?
Is it slow when you use the supplied remote?

Playback is fine once I get to play a file.

The battery is fine. I have a battery tester and it has full charge.

I’ve never used the supplied remote as my remote controls other things. In order to test with the supplied remote do I just plug in the usb dongle?

I’m pretty sure it is the update causing the issue since playback on BBC iPlayer is okay.

Playback of files on my NAS has never been great but it got massively worse after the update.


I’m having the same issue.
Something is causing the CPU to bu fully utilized at 100%.


After a second reboot the slowdown is no longer an issue.

To clarify: you’re experiencing an issue with the IR remote and only during playback?


You are right, I was not very clear.

The system installed the update and then rebooted itself.

I noticed it because my TV automatically switches input to an active device, and I saw my Vero4k starting kodi (I don’t know if it was a full reboot or just a kodi restart)

The system at this stage was very slow and unresponsive. At first I thought the remote battery was dead, but opening the system infos screen revealed that the CPU utilization was at 100% ( one of the core)

I activated the debug log and proceded to fully reboot the device, It took a while to do it but eventually it happened, and once rebooted the slowdown was no longer there and CPU utilization back to nornal with system being responsive as always.

I’m not sure this is the issue the user is reporting (IR remote problems during playback) and you still haven’t clarified if you are using an IR remote.

You also don’t clarify if the issue is now resolved for you. If there was high CPU usage for a period of time it was likely add-ons or library updating when Kodi restarted

I have had a few issues with the GUI update on the Vero over the years and when it causes a problem I have gone in via telnet and run
sudo apt full-upgrade
which has fixed it so far.
I wouldn’t do that by default as the GUI update is usually fine, but when it isn’t, try going full Linux on it!
Sam will probably shriek “Nooooooooooooo!” at this point

I haven’t got around to trying the original remote or sorting the log files yet, but I’m also having problems with BBC iPlayer too. A programme plays okay and then when I try to go back in the programme it often freezes. It never did that before the update. If I press stop I can exit the programme okay and then play from where I left off.

Hopefully i will try the orignal remote this weekend but the Vero is difficult to get to.

Can I sort out the logs by logginf in remotely?

Correct. When someone has an issue with the regular updater the suggestion would be to ssh in and run…

sudo apt-get update && sudo apt-get dist-upgrade

which will usually either correct a failed update, or else give a hint of where a problem lies.

Are you asking on how to get logs via ssh? If so then that is just grab-logs -A to gather a full log set and it will return a url of where they got uploaded to.

Hello, I am also experiencing instability problems when playing video files. This since the last update and every day the grimaces are more and more frequent.
This is the log.
Any idea of what’s wrong?

Kodi crashes with this:

May 19 16:55:03 osmc mediacenter[2967]: /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/osmc/lib/libamcodec.so: undefined symbol: audio_decode_stop

We don’t know where this symbol comes from. It is not introduced by OSMC.
I suggest reinstalling OSMC. This will definitely solve your problem.