OSMC Pi Config menu bugged


I have acquired the bluetooth dongle. and my OSMC is setup on a RASPI3.
Everything works all right. I have updated my setup.

I’m trying to enable the bluetooth, but the menu is unusable (RASPI config in OSMC Menu).

My log : https://paste.osmc.tv/ukohamizum

Does it happen with the OSMC skin?

Actually I have setup extra skins (Aon and another one), I have switched from skins to skins to test them, and this bug appeared afterwards.
this Skin is the only one that shows me “My OSMC” in the main menu. it is the estuary skin.

You can always find MyOSMC under in the addons menu under Program addons no matter what skin you use.

Thanks for your assistance.

I have tested the “my OSMC” application with the various skins, including the default OSMC skin.
And it seems that the problem is there in each skin. What is strange is that the other topics of the menu (network, app…) still work. It’s only the Raspberry part that is no good.

Is your device up to date?

it is. I have done a good old fashion “sudo apt update”.

My next step : restart from scratch with a bigger memory card. I’ll update the discussion if it solves my bluetooth situation.

A note here - sudo apt update will only update the repos containing the software upgrades. It is then necessary to issue sudo apt dist-upgrade to actually upgrade the system.

Hi, got the same problem not seeing any content in Pi Config, regardless the skin choice.
apt upgrade didn’t fix it.
Could you solve this problem?

EDIT: solved by deleting the settings.xml

Are you on the devel version of OSMC (Kodi 19) by any chance?

no,im on kodi 18.9
i think this problem appeared after an upgrade a few minar versions ago
i fixed it like described in the edit in my last post