OSMC Pi3 sound processing after january 2018 update

I will try to explain an issue I’ve came across after installation of the last january 2018 update.
It is an issue related to movies sound.

First, my setup:

I have OSMC installed in a Raspberry pi3, with my movies library siting in an external disk.
The Pi is connected to a Sony Android TV trough a HDMI cable.

The TV supports up to 7.1 channels input (including Dobly and DTS).
As the sound dynamics is better after being processed by OSMC, I usually don’t use passtrough,
but opted to use a 3.1 output (as I have a simple sound bar with a nice subwoofer connected to my TV).

This has been working just nice for over one year.
After the last january 2018 update, I’ve got several issues in which some movies are reproduced with sound effects but without voices !
The way I’ve found to get back the voices is to enabled passtrough - or in some cases enable passtrough then disable it again !

But it would be great to get sound processing (without passtrough) working again.

I hope I was clear enough.

This is the audio output section of my guisettings.xml:

        <ac3passthrough default="true">true</ac3passthrough>
        <ac3transcode default="true">false</ac3transcode>
        <atempothreshold default="true">2</atempothreshold>
        <audiodevice default="true">PI:HDMI</audiodevice>
        <boostcenter default="true">0</boostcenter>
        <config default="true">2</config>
        <dspaddonsenabled default="true">false</dspaddonsenabled>
        <dtshdpassthrough default="true">false</dtshdpassthrough>
        <eac3passthrough default="true">false</eac3passthrough>
        <maintainoriginalvolume default="true">true</maintainoriginalvolume>
        <passthrough default="true">false</passthrough>
        <passthroughdevice default="true">PI:HDMI</passthroughdevice>
        <samplerate default="true">48000</samplerate>
        <streamnoise default="true">true</streamnoise>
        <streamsilence default="true">1</streamsilence>
        <truehdpassthrough default="true">false</truehdpassthrough>
        <volumesteps default="true">90</volumesteps>

It looks as if the center channel is missing. Can you post debug logs, please.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Also the brand and model of the sound bar could help.


thanks for the suggestions.
I’ve been looking into the logs, but nothing seems to be related to the issue.
This is something that only happens in some (apparently) random situations.

But it happens only in 3.0 and 3.1 mode (when there is a specific request for processing a central channel).
I will try also in 5.1 mode.
Forcing 2.0 and 2.1 works just fine.

Try to set Settings -> System -> Audio -> Output Configuration to “Best match” instead of “Optimized”.

We can’t help you much without logs.

1 Like

Do you have OMX player enabled in your player settings? Reason I ask, is that random loss of the center channel has been a permanent issue for me when running LibreELEC on a Pi connected to my 7.1 AVR. The only way to fix it, was to disable OMX and only allow MMAL acceleration. I never found that to be satisfactory, as this was not addressing the root cause. My experience was that loss of the center channel was even random for the same title. One moment initiation of playback would be fine, stop and re-start, and center channel gone. Never found a pattern as to what broke or fixed it.

1 Like

Yes. you’re right.
found this in kodi.log:
10:44:44.499 T:1201664768 NOTICE: thread end: OMXPlayerAudio::OnExit()

everytime the processing of the center channel fails.

Yes I had it. I’ve disable it and kept only MMAL.
It seems to be working.

anyway, this was not an issue before the january update.


These are my last logs:

and the issue of no sound (before disabling omxplayer), happened when playing the movie in the timestamp of kodi.log:

“10:44:28.332 T:1925323264”

If you have audio set to Optimized, set it to Best Match instead.

Yes. I’ve done it.
Best match and omxplayer disabled: works.

But the oddity in this is that before january update it worked ok.