OSMC PlexForKodi doesn't honor Resume

If I watch part of a movie/show on my Plex server on my PC and try to resume it from my PlexForKodi in OSMC on my Raspberry Pi 3+, the show resumes at the correct time BUT the timebar (horizontal bar that runs along the bottom of the screen showing how far I am into the show) resets to 00:00.

If I stop watching the show on my Raspberry Pi, it overwrites the incorrect timestamp. If I use FFW or REW controls, it jumps to the 00:00 displayed time…

I would like the timestamp to be correctly reflected in the horizontal timebar and stored correctly when I stop watching the show. Any suggestions?

I can’t reproduce with the current 0.1.6 Plex for Kodi.

It happens for me every time… If I watch a show for a few minutes (even on my RasPlex), stop it, and go back into the show, it asks if I want to resume. I say Yes.

Then, it briefly flashes the timestamp correctly, but when the show begins to play, it resets to 00:00.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I followed the steps above and got the following URL. https://paste.osmc.tv/iwirisakax

Can you open the Plex add-on, click on your login id at the top of the page and then select ‘settings’. In settings>video make sure the following is set and retest…

Local Quality (original)
Allow Direct Play (checked)
Allow Direct Stream (checked)

Thanks for your reply. All those were already set when I checked them.

If that is the case then I would go through the settings in your plex server because it is transcoding when it doesn’t need to and that seems to me like a likely culprit. You might also look to see if there is any updates to the plex server your running. I tried to reproduce again on my system (plex server on Win10 current, plex for kodi 0.1.6 on Pi 3b+ and current stable OSMC) and I cannot find an issue.

Thanks again for your replies. I appreciate the assistance.

My Plex Server is on Win10 current (64-bit) and is up to date. Plex for Kodi 0.1.6 on Pi 3b+ and current stable OSMC – a match to your setup.

The Transcode settings on the Plex server are:
Transcoder Quality: Automatic
Transcoder default throttle buffer: 60
Background transcoding x264 preset: Medium
Use hardware acceleration when available: CHECKED
Maximum simultaneous video transcode: 4

Are any of those settings suspect? If that’s not the right place to look, can you tell me where (else) to check?

In the settings on the plex server you should be looking at web client for the settings that affect your transcoding.

Thanks again for your reply.

In Web Client, under Debug:
Direct Play: CHECKED
Direct Stream: CHECKED

Under Quality:
Video Quality: Maximum
Automatically adjust quality (beta): UNCHECKED
Play smaller videos at original quality: CHECKED
Home Streaming:
Use recommended settings: UNCHECKED
Video Quality: Maximum

After spending some more time comparing my logs with yours I think I was mistaken in thinking your log was showing transcoding. Your settings look fine in Plex. I did manage to figure out the issue and reproduce it myself. The problem is that the plugin does not like the OMX player and that is messing up the reading and saving of time stamps with this add-on. If you disable that (which is a default settings) then the plugin should work as expected…

(In Kodi) Settings>Player>Videos>Allow hardware acceleration - OMXPlayer (disable)


Thank you! It worked! That problem had been frustrating me for so long. I sincerely appreciate your help.