OSMC - Raspberry pi 3 - External HDD USB3

Hi, I’m trying to connect my new HDD (Western Digital My Book 8TB) to Raspberry pi 3 on OSMC. I tried a Flash usb drive of 4GB and it works but new HDD isn’t recognized. I tried to found it on /mnt or /media but it wasn’t here. My HDD is formatted on NTFS under Windows10. Windows PC read it without issue. What can I do to connect it to raspberry pi 3? Raspberry and HDD have two separate power adapter connected to power line. Thanks.

Provide logs grab-logs -A so that we can advice further

I tried also on Raspbian, LibreElec, on one old Laptop with linux distro but I can’t access the HDD… Windows no issues…

This doesn’t look good
Feb 05 15:04:05 osmc kernel: print_req_error: critical medium error, dev sda, sector 15628052440 Feb 05 15:04:05 osmc kernel: Buffer I/O error on dev sda, logical block 1953506555, async page read Feb 05 15:04:05 osmc kernel: Alternate GPT is invalid, using primary GPT

If you don’t have an issue on Windows it might be a power or interface issue.

Alternative you might want to try to partition and format the drive on OSMC

I don’t understand that error… I found the HDD with lsblk:
sda 8:0 0 7.3T 0 disk
|-sda1 8:1 0 16M 0 part
`-sda2 8:2 0 7.3T 0 part
How can I format it on osmc??? I have ssh open but I’m not familiar with linux command…

If you don’t mind to lose all data on the disk you could format it with mkfs.ext4 -L osmc_drive /dev/sda2

After that unplug and replug and run mount to see if the drive is mounted.

But with the errors doesn’t look good.

I launched the mkfs but I don’t understand if it run… I don’t understand that error, in windows the HDD works fine, I checked with WD software and Crystaldiskinfo and SMART is fine…

Did you check mount afterwards?

As mentioned can be power, interface (I think some one else wrote about issues with USB3 device) or cable issue.

I can’t format it from SSH, it doesn’t run… Now I reformatted it under Windows and I hope this time I could see it on osmc. Last chance is to use GParted Live to format…

Ok I give up on it. I think USB 3.0 has some issue, on Windows if I attach it on USB2.0 I have to install a driver for device, maybe on linux this is not possible. lsusb and lsblk found it but it’s impossible to mount for some strange reason. Thanks for help.