OSMC, Raspberry Pi 3b+ and waveshare 7.9 screen

Hello everyone,

I have Raspberry Pi 3 b+ and waveshare 7.9" screen attached to it.

I added following to config.txt file to run raspberry pi with this screen and it is working while in boot:

Code: config.txt

hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3

but when gui starts the picture does not fit on the screen

when I try to change it to native resolution (which is 400x1280) nothing changes and it does not rotate the screen to 270 degrees.

does anyone know what to do please?


Have you tried contacting the manufacturer of the screen for advice?

I did but here is the thing… it works perfectly while in the boot section or while I am using raspbianOS or crankshaft with commenting out dtoverlay=vc4-kms-v3d

on the other hand it works perfectly without “display_rotate=3” but when I try to rotate it does show only some part of the gui.

is there anyone who can help with OSMC Gui Rotation?

You can use KMS, but it’s not recommended.

how will I use KMS? is there any guides to do this?

if you can share with me I would be appreciated.

You can change config-user.txt

My suggestion is to ask for exact clarification from ‘WaveShare’.

Bump, I believe I have the same issue.
In my case, I have a projector with resolution 854x480.
To get that resolution, I need to use this:

hdmi_timings=854 0 26 80 104 480 1 3 2 15 0 0 0 60 0 24595200 3

This works with retropie and raspbian OS. Also it works at boot with OSMC.
However, when OSMC finishes booting, it is switching to FullHD resolution.
Luckily, my projector can handle FullHD resolution (the above-mentioned waveshare display probably not), but the downscaling makes the image look unsharp.
I guess that it has to do with Settings/System/Display/Resolution, which is set to FullHD, but there is no 854x480 resolution there!
Is there a way to disable osmc resolution changes after boot and keep boot resolution?

I have made a bit of progress with this. I have managed to get 854x480 working with fkms, but audio is not working with fkms. :frowning:


#osmc tends to remove hdmi_mode from config-user.txt
include config-user.txt


hdmi_timings=854 0 26 80 104 480 1 3 2 15 0 0 0 60 0 24595200 3

It seems fkms no sound issue is a known bug: Kodi 19 no sound over hdmi using fkms · Issue #4634 · raspberrypi/linux · GitHub
It seems I need to upgrade kernel from 5.10 to 5.15.
I there a guide for kernel upgrades?

You could build this from source. I’d be surprised if fixes weren’t backported to 5.10 however.

I have managed to get it working, but without osmc, because building kernel from source would take a lot of work.

  1. Install Raspberry OS on an SD card.
  2. Run “rpi-update” to get the latest kernel.
  3. Edit config.txt: switch from kms to fkms and add your hdmi_* parameters
  4. Install “kodi” package.
  5. Run Kodi Standalone from the menu. Everything works now!
  6. To automatically boot into Kodi, you can append a line with “@kodi” to /etc/xdg/lxsession/LXDE-pi/autostart

Is there a reason, why OSMC is not based on Raspberry Pi OS? I mean, I wanted to use OSMC over LibreELEC, because it is more flexible, but Raspberry Pi OS seems to be more flexible than OSMC. So whats the point of OSMC?

OSMC is based on Debian.

The purpose of OSMC is to provide a media center and the APT package management system.