OSMC + Raspberry Pi B+ & Osoyoo 3.5 v6.1 LCD Screen

Hi Guys,
I am a total newbie to this so also apologies if this is a stupid post (but please don’t have a go at me, although I’m sure you wouldn’t any way!)
I have bought an Osoyoo 3.5 Touch screen LCD V6.1 for a tenner and I’m trying to get it working with OSMC.

I now have an interesting situation!

I don’t know how to/if I can add photos so they are uploaded here.

When I turn on the Pi I get the Raspberry Icon appear in the corner of the LCD with a few lines of text below it (see Image 1)
After a few seconds the OSMC Menu appears on the HDMI Display (photo 2).
I then tried getting to the terminal by using the power menu and selecting exit and then pressing esc at the splash screen.
Interestingly enough the Splash Screen actually loaded on the LCD screen (photo 3) and the HDMI screen went blank. The terminal then also loaded on the LCD screen (photo 4) and I was able to interact with it normally.

Has anyone got any ideas of what I need to change to get this working totally on the LCD? I am feeling positive about it as the splash screen loads on the LCD.

In the interest of sharing the back ground story to get to this stage I haven’t done anything special other than a lot of filtering through google turning up nothing.

In the end I followed urezdaye post from Here
Which modified slightly is:-

Login as: osmc
Change to root user using: sudo sU
COMMANDS: Update your OS: 1. sudo apt-get update 2. sudo apt-get dist-upgrade
Download Driver from Kedei (Manufacturer for screen at http://en.kedei.net/raspberry/raspberry.html)
(Based on Version you have on back side of screen, select the following link and replace “http://…”) sudo wget http://en.kedei.net/raspberry/v6_1/LCD_show_v6_1_2.tar.gz
(Extract Driver) tar -xzvf LCD_show_v6_1_2.tar.gz
(Go to Driver) cd LCD_show_v6_1_2
(Enable display): ./LCD35_v

and I have also enabled SPI in the OSMC Settings.

I’m afraid I’m out quite a bit but will try anything posted as soon as I can and let you know the results if anyone is interested.


“Upload” button on the bottom right

fbcp allows you to copy the framebuffer of the main display to the LCD, however I don’t think you could get video on it. I think you’ll get about 20fps at the most on one of these screens via SPI.

The Raspberry Pi forums have some background on this. As long as you can get the display to show some output already, it seems like you just need to use fbcp and set that up to run on boot. Kodi is a GLES application, so I am not sure if that will work as expected however. It already seems that the FB is duplicated if you can get the splash screen up.

You can upload photos with the upload button here:

Probably makes more sense to use imgur and paste the link here.

I think ogles does not work right now with those lcds.

Thanks Frinken and ActionA for the help on the image upload. I thought I had been through all the options, oops!

Thanks for your response Sam_nazarko, I had seen about using fbcp on circuitbasics here, the post was based on raspbian so I didnt find it very helpful and as I wasn’t sure I was chasing the right lead. I will take your advice and have a dig on The Raspberry Pi Forums and post back if I get any closer.

Mcobit you might be right, I will have a dig anyway and see if I can find anyone who has got a workaround.

Thank you all.

I don’t think fbcp will work for Kodi unfortunately. You’d need a way of getting the video at the dispmanx layer, then passing it to the screen.


Ok, No worries. Was a nice thought.
I was hoping to get the display up and running so I can put a unit on each of my old HiFis round the house and stream music from my Kodi library in a different room.
Tried running kodi through Rasbian os but on my old Pi b+ it just seemed to hang when trying to load it.
Seems I might have to run them through the Yatse phone app rather than the direct screens.

Thanks for your help Sam, Love the Osmc Project!

You could make a simpler solution with mpd and a non-gles frontend to stream music.

Your right Mcobit.
I have just been looking at that since your last post.
I will have to dig into it a bit more.
I can see why it wont work now after reading a few forums explaining why the fbcp wont work with the kodi system.
I had assumed all the graphics on a pi would be handled in a similar fasion regardless of os but I can see I was a bit of an idiot making that assumption!!
Thanks, Readie.

On Raspbian Jessie KODI 17.1 and fbcp work together. The generic way to get a SPI-display up and running doesn’t seem to work with OSMC (enable SPI in MyOSMC, add “dtparam=spi=on” and “dtoverlay=piscreen” to /boot/config.txt).