OSMC RC and empty repository

Hi everyone,

I just installed OSMC RC and I can’t get the addons repositories to update. I try to force refresh and to delete the ‘addons16.db’ file, but nothing.

My internet connection is working (slowly), since I installed samba, and when I try to check for update or force refresh, nothing show up. So I think it doesn’t even try to update.

Do you have any idea on how to solve my problem? Maybe I should just install raspbmc until the final release?

Thanks a lot!

sudo apt-get update?

I tried after your comment (and upgrade too) but it didn’t change anything.
I’m going to bed now (it’s 2 in the morning in France), so I won’t answer before tomorrow. Have a good day/night!

My debug log returned this:

I’ll try to look more into that tonight.

Edit: I installed another repository and it worked fine.

Refreshing the repository sometimes resolves this

S

I am having the same issue with a fresh install of OSMC on RPi2.

I also tried force refreshing the repo and deleting the “addons16.db” file with no luck.

@Tibboh you mentioned that you installed another repository and it worked fine is there a way to reinstall the official “Kodi Add-on repository”?

Greetings,

Since yesterday I am a proud owner of a Raspberry Pi 2 and I installed OSMC and I like it a lot.

Although I am having the same problem with a certain repository, it just keeps showing up empty.

Forcing refresh, fresh installs, etc. nothing seems to work.

The repository I am unable to install is the Unofficial Pulsar Repo LINK

Ask the Pulsar people? This is not an OSMC issue if you have confirmed internet connectivity.

Hello,

Today I have make a new install of OSMC, and all is working correctly.

I like to much this new design !!!

The only thing that it’s happening is a problem with accesing the content of repository.

I have found this problem instaling the pulsar unofficial repos, and I’ve seen that we have a problem with the libcurl3 library and RC4.

It’s installed the 7.38 version, and it has a problem establishing the comunication.

My Log file where I’ve found the problem:

DEBUG: ADDON: cpluff: ‘Not all directories were successfully scanned.’
17:29:57 T:3024453632 DEBUG: CGUIMediaWindow::GetDirectory ()
17:29:57 T:3024453632 DEBUG: ParentPath =
17:29:58 T:2838754336 ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
17:29:58 T:2838754336 ERROR: CCurlFile::CReadState::Connect, didn’t get any data from stream.
17:29:58 T:2838754336 ERROR: Open - failed to open source https://icanuckxbmcrepo.svn.cloudforge.com/pulsarunofficialrepo/trunk/addons.xml.md5

I’ve tried in the raspberry console to execute curl command with the parameter “–ciphers ALL”, and it works properly. I can see all the content of the repository.

osmc@osmc:~/.kodi/addons/repository.pulsarunofficial$ curl -v --ciphers ALL https://icanuckxbmcrepo.svn.cloudforge.com/pulsarunofficialrepo/trunk/addons.xml | more

  • Hostname was NOT found in DNS cache
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0* Trying 208.75.199.102…
    0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0* Connected to icanuckxbmcrepo.svn.cloudforge.com (208.75.199.102) port 443 (#0)
  • successfully set certificate verify locations:
  • CAfile: none
    CApath: /etc/ssl/certs
  • SSLv3, TLS handshake, Client hello (1):
    } [data not shown]
  • SSLv3, TLS handshake, Server hello (2):
    { [data not shown]
  • SSLv3, TLS handshake, CERT (11):
    { [data not shown]
  • SSLv3, TLS handshake, Server finished (14):
    { [data not shown]
  • SSLv3, TLS handshake, Client key exchange (16):
    } [data not shown]
  • SSLv3, TLS change cipher, Client hello (1):
    } [data not shown]
  • SSLv3, TLS handshake, Finished (20):
    } [data not shown]
  • SSLv3, TLS change cipher, Client hello (1):
    { [data not shown]
  • SSLv3, TLS handshake, Finished (20):
    { [data not shown]
  • SSL connection using TLSv1.2 / RC4-SHA
  • Server certificate:
  •  subject: C=US; ST=CA; L=South San Francisco; O=CollabNet, Inc.; CN=*.svn.cloudforge.com
    
  •  start date: 2014-03-07 00:00:00 GMT
    
  •  expire date: 2016-05-20 12:00:00 GMT
    
  •  subjectAltName: icanuckxbmcrepo.svn.cloudforge.com matched
    
  •  issuer: C=US; O=DigiCert Inc; OU=www.digicert.com; CN=DigiCert High Assurance CA-3
    
  •  SSL certificate verify ok.
    

GET /pulsarunofficialrepo/trunk/addons.xml HTTP/1.1
User-Agent: curl/7.38.0
Host: icanuckxbmcrepo.svn.cloudforge.com
Accept: /

< HTTP/1.1 200 OK
< Date: Mon, 06 Apr 2015 19:12:43 GMT

  • Server Apache is not blacklisted
    < Server: Apache
    < Last-Modified: Sun, 29 Mar 2015 19:48:20 GMT
    < ETag: “623//trunk/addons.xml”
    < Cache-Control: max-age=604800
    < Accept-Ranges: bytes
    < Content-Length: 84694
    < Content-Type: text/plain; charset=UTF-8
    <
    { [data not shown]
    1 84694 1 1182 0 0 1053 0 0:01:20 0:00:01 0:01:19 1062<?xml version="1.0" encoding="UTF-8" standalone="yes"?>







    executable


    Pulsar Providers
    Pulsar Providers

I have search for downgrade or upgrade the libcurl3 library, but , for debian, is the latest, and for downgrade, there isn’t lowers version using apt-search.

Any one know, how to include in XBMC the parameter --ciphers ALL, or how we can install lower version of this libcurl3 library.

Thanks

Oscar

I have the same problem, the default repository doesn’t seem to update and randomly when doing a refresh I get the sad smiley face and Kodi crashes/reboots.

Hello,

the error on my kodi.log is the following:

CCurlFile::FillBuffer - Failed: SSL connect error(35)

I’ve been following the method code CCurlFile::FillBuffer.

I’ve found that in the following method, at the end, there is an ‘if’ to check the chipers list

void CCurlFile::SetCommonOptions(CReadState* state)
{
CURL_HANDLE* h = state->m_easyHandle;

g_curlInterface.easy_reset(h);

// Setup allowed TLS/SSL ciphers. New versions of cURL may deprecate things that are still in use.
if (!m_cipherlist.empty())
g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str());
}

I’ve checket that the variable m_cipherlist, y empty in …

CCurlFile::CCurlFile()
: m_writeOffset(0)
, m_overflowBuffer(NULL)
, m_overflowSize(0)
{
g_curlInterface.Load(); // loads the curl dll and resolves exports etc.
m_opened = false;
m_forWrite = false;
m_inError = false;
m_multisession = true;
m_seekable = true;
m_useOldHttpVersion = false;
m_connecttimeout = 0;
m_lowspeedtime = 0;
m_ftpauth = “”;
m_ftpport = “”;
m_ftppasvip = false;
m_bufferSize = 32768;
m_postdata = “”;
m_postdataset = false;
m_username = “”;
m_password = “”;
m_httpauth = “”;
m_cipherlist = “”;
m_proxytype = PROXY_HTTP;
m_state = new CReadState();
m_oldState = NULL;
m_skipshout = false;
m_httpresponse = -1;
m_acceptCharset = "UTF-8,;q=0.8"; / prefer UTF-8 if available */
}

I’ve tested in the console of OSMC, with the command curl -v --ciphers ALL http://…, and works properly.

My question it’s the following, can we put the ‘ALL’ value to m_cipherlist to work inside XBMC, like putting --ciphers ALL in the console.

If I change this value, can some one explain how to build again the entire OSMC.

Thanks in advanced !!!

Oscar

Sorry, I left the forum for a while.

At first, I wanted to install the “Unofficial Pulsar Repository” which didn’t worked, then I switched to “Kodi Underground”. I don’t know about the “Kodi add-on repository”, sorry…

Thank you very much. !!!

You are ok, with this repository works properly.

https://github.com/prilly/repository.kodiunderground

Great !!!

Oscar

1 Like

Hey.
I got the same issue but this repo isn’t up to date…
look at this :
23:31:18 T:2613044256 DEBUG: FileManager: copy http://kodi.speedbox.me/svn_kodi/trunk/plugin.video.pulsar/plugin.video.pulsar-0.4.7.zip -> special://home/addons/packages/plugin.video.pulsar-0.4.7.zip
23:31:18 T:2613044256 DEBUG: CurlFile::Open(0x469f390) http://kodi.speedbox.me/svn_kodi/trunk/plugin.video.pulsar/plugin.video.pulsar-0.4.7.zip
23:31:18 T:2613044256 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 404

The repo need an update. An other version is available on the repo but the xml file is wrong.
How can I update it ?

http://kodi.speedbox.me/svn_kodi/trunk/plugin.video.pulsar/


UPDATE : This repository is back on the road. The owner made the update.

https://github.com/prilly/repository.kodiunderground/issues/1#issuecomment-90864406

Thanks for getting this fixed.

1 Like

Hello, New to Kodi… But I was a user of Rasbmc and I wad able to get Addons by following instructions. Now nothing is working. The Kodi repository is empty even if I erase the .db file and reboot. I have the dual boot setup. Where is a simple a-z procedure to get it working ?? I am starting way behind you guys and I spent a lot of time on the Web trying to get the solution.
Thanks

I’ve you tried to follow all steps like that: http://tutorial-iptv-xbmc.blogspot.ch/2015/02/install-pulsar-repo-setup-pulsar-add-on.html
with packages provide below ?