OSMC RC Rasp pi 2 - tvheadend - hdhomerun - no tv adapters showing

I enabled the tvheadend server that is included. I logged into tvheadend -> config ->dvb inputs. All I see is a dropdown folder for tv adapters but my hdhomerun (hdhr3-us) does not show up. Do I need to ssh in and install some sort of dvbhomerun…etc, so that the pi/osmc can find it? I want to make sure something of that nature is not already included before I go doing this.

I’m also really interested in whether this works or not. In Raspbmc, you needed to enable the dvbhdhomerun addon through the Kodi interface (if I remember correctly), so they are part of the Helix Kodi repository (I think). I’m still on a RPiB+ Raspbmc build, but planning to upgrade to RasPi2B/OSMC soon. But only if I can be sure I don’t have to spend another two weeks configuring everything. My wife would kill me. Please let me know if you figure this out. :slight_smile:

So, I started the RPi2 project earlier than anticipated. I’m at the point where I can’t get Tvheadend to show the HDHomerun adapters. And I can’t find the driver add-on in any of the OSMC repositories. Even if it was there somewhere, I doubt the previous version would work with the new kernel. I am planning to try this:

I think I need to download the armhf version, but I’m not 100% certain. Any suggestions?

Suggest you use the compile-it-yourself version detailed by HarryL, but I had to also generate the accesscontrol file, both detailed in OSMC RC Unable to install TVHEADEND - #49 by DBMandrake.

1 Like

That thread is about updating tvheadend, as far as I can tell. I read most of it yesterday, but maybe I missed something. Just to clarify, are you saying that the issue is potentially with tvheadend and not the hdhomerun drivers? I guess it’s possible, I just had assumed they weren’t showing up because the system couldn’t see them.

I’ll give that a try, though. Thanks!

Add dvb_hdhomerun to /etc/modules

Thanks for the reply. I’m sorry to say, I’m still a bit of a linux noob and I’m not sure how to do that. If you could give me a little more detail, I’m sure I can figure it out. Is it a matter of just moving a single file or doing a new install to that location?

btw- OSMC is beautiful! Will it run on the 1st generation B boards (B and B+)?

EDIT: Nevermind, I think I found it

relevant bit:
Set the kernel module to start at boot
sudo echo dvb_hdhomerun >> /etc/modules

At least, I think that’s what you’re saying, Sam. Let me know if I’m mistaken. I’ll try this tonight. Thanks again.

@kphammond9: The impression I have got from both my own experience any the several other Tvheadend threads is that there are problems with the App Store version. However you may be lucky!

Ok, I’ll try the quick /etc/modules fix tonight and then, if I still have problems, I’ll follow HarryL’s tutorial. Being not-very-linux-savvy, I was scared off a bit by the wall o’ code. But I’ll roll up my sleeves and give it a shot. :slight_smile:

So, no dice on either one. After the weekend, I’ll try HarryL’s walk through again with a fresh install. I was tinkering around with modules and libraries a bit, so maybe I broke something. The process itself was pretty straightforward, even though I didn’t always know exactly what I was doing.

Please post back if you had any luck with this and what you did, as I am having the same problem with my hdhomerun not showing up under adapters. I’m also not very linux savvy, so getting in to the compile it yourself stuff tends to get a bit over my head!

It worked for me with a fresh install following HarryL’s instructions.

Make sure you don’t install anything from the app store first. Just start with a fresh OSMC image. I had to do an update (sudo apt-get update) before I could run the build commands in his post, but after that it was pretty straightforward. Make sure to include the hdhomerun-specific stuff as well. If you don’t know where to start at all, PM me and if the timing works out ok, I can walk you through it.

Great, thanks for posting back! I will have to give it another go using those instructions. I’m not sure when I will get to it, but thanks for the offer of walking me through it! I’ll message you if I have any issues!


I have tried to assemble the information from various posts in a way that might help you - see [Obsolete] Instructions for Viewing Live TV. Feedback on those instructions would be helpful.



Thanks for that! It looks like it will be very helpful. It will probably be the weekend before I can mess with it again but I will let you know the outcome. Thanks!

So I had a little bit of time to mess with this and got futher than I was before. I followed the instructions posted here by @EMJB. Here are my comments/where I’m now stuck.

I did a fresh install of OSMC and started following at step 4.4 since I am installing for the hdhomerun. I ran in to issues with the make command not being installed. I ended up jumping ahead to step 5 which installs build-essential and cmake, and then went back to finish step 4.4 with no other issues.

Everything seemed to compile and install fine and I now see the hdhomerun in the adapters list, woohoo! Now I’m stuck at step 6.4. I am in the US on cable, so I’m selecting “ATSC Network” as the network type and then “United States: us-Cable-Standard-center-frequencies-QAM256” as the predefined mux. When I go to muxes I don’t see anything, so I add it manually. Nothing seems to be found, though.

When I select the hdhomerun under the adapter list and enable it, the “Networks” drop down is not being populated. It’s not very intuitive, but if I select the hdhomerun folder and set that to ATSC, the network I created then shows in the dropdown for the adapter. It’s not finding any services, though. The mux tab shows the scan status as “idle” (initially said “pend”) and the result as “fail.” Previously with Raspbmc and openelec I was able to find over 700 services, so I’m not sure what I am doing wrong with the scan.

I’m out of time to keep messing with it tonight, but will hopefully get a chance to play with it more tomorrow night, so if anyone has any pointers or knows what I’m doing wrong I’d greatly appreciate it!