OSMC RC Unable to install TVHEADEND

I have the same problem as gansde, and have tried perifrastico’s suggestion. Have checked that the Hauppage device appears OK in the dmesg report.

Same here, tv dongle installed, tv headend server enabled but no Configuration tab.

I have build tvheadend at my own (wiki tvheadend) after that i replace the version from the appstore with my own version.
And it works now perfect.
I think there is a compile error at the version from the appstore version.

@Stephan, can you give a step-by-step guide to what you did to build your own and install it?

1 Like

Have just tried rebuilding Tvheadend using the instructions here:


but replacing “aptitude” with “apt-get” and ignoring the first instruction ("… wget"). The build seemed to go OK. I then copied the results into “/usr/bin”, overwriting the existing “tvheadend” file, and rebooted. The new build is recognised in the title of the x.x…x.x:9981 web page, but none of the tabs appear so there is something else that needs doing.

Just use the git version like this.

sudo -s

apt-get install git build-essential pkg-config libssl-dev dvb-firmware-osmc dvb-tools libdvbv5-0 liburiparser-dev liburiparser1 libavahi-client-dev zlib1g-dev libavcodec-dev libavutil-dev libavformat-dev libswscale-dev

add " libhdhomerun-dev libhdhomerun1 hdhomerun-config cmake " for hdhomerun network tuner.

cd /usr/src
git clone https://github.com/tvheadend/tvheadend
cd tvheadend

run using

/usr/src/tvheadend/build.linux/tvheadend -u osmc -g video -C &

Done use homepage http://IP/:9981

for hdhomerun you need dvb-hdhomerun software “wrapper”.

cd /usr/src

ln -s /usr/include/libhdhomerun/ /usr/lib/libhdhomerun

wget http://downloads.sourceforge.net/project/dvbhdhomerun/dvbhdhomerun_0.0.15.tar.gz

tar zxvf dvbhdhomerun_0.0.15.tar.gz

cd /usr/src/dvbhdhomerun-0.0.15/userhdhomerun
make install

run like this
/usr/local/bin/userhdhomerun -u osmc -g video -f

Remember to load the kernel modules first:
modprobe dvb_hdhomerun

i do it in rc.local like this

modprobe dvb_hdhomerun
sleep 4
/usr/local/bin/userhdhomerun -u osmc -g video -f &
sleep 4
/usr/src/tvheadend/build.linux/tvheadend -u osmc -g video -C &

The hdhomerun tuner needs to be on the same network when the dvb_hdhomerun module is loaded and you run the userhdhomerun wrapper.

Opdated with avahi support.
Opdated with libav support

@HarryL - see you have edited last post - do the changes affect non-hdhomerun users?

If so I need to rerun it - the original version seemed to have solved the problem with no configuration tab when viewed with Windows, but still didn’t find any channels.

@HarryL - I should have said I get the following failures when running the above:

“checking for cc -mmmx”
“checking for cc -msse2”
“checking for cc libiconv”
“checking for cc -hdhomerun/…” (but I am not using anhdhomerun device)

Are any of these important?

no :wink:

it’s probably best to delete /home/osmc/.hts folder first… so you start clean with tvheadend…

It works quite perfect, thanks. I’ve got the Servers Surface with all Tabs. Services scanning still didn’t work only for the first mux. No further muxes were detected. Muxes added by Hand are not scanned.

With the latest edit to HarryL’s post, I now have found most of the channels, but still no Live TV option in the main Kodi menu.

Edit: My mistake - I hadn’t mapped the channels - so now moved forward to stage where I have the channels appearing in KODI, but when I select a channel Tvheadend HSTP Client complains that no input has been detected.

when I execute that command, I get this:

root@osmc:/usr/src/tvheadend/build.linux# tvheadend -u osmc -g video -C &
[1] 6842
root@osmc:/usr/src/tvheadend/build.linux# bash: tvheadend: command not found

[1]+ Exit 127 tvheadend -u osmc -g video -C

do you know what is wrong?

Nevermind, figured it out, had to exit back to home directory

check your coax cable, it has to be new ones(shielded), the same with the T splitter if you use one.

and it takes tvheadend at least 30 min to maps channel here…
signal on the mux needs to be at least 65%…

and don’t have your tuner near(20 cm) an access point or other wireless devices…

I moved to OpenELEC now and everything runs perfect with TVHeadend.

1 Like

Harry, is there to make TVheadend run automatically at start up without having to ssh to it?

Sorry, nevermind, figured it out here:


I have updated the version of TVHeadend available in the App Store

On initial setup I see

  • The configuration tab
  • No segfault

If you still have a problem let me know:

  • The Pi you are using (1 or 2 / ARMv6 or ARMv7)
  • Tuner you are trying to use


1 Like

Have just tried to install the above on my Pi 2 “over the top of” a version compiled in accordance with HarryL’s instructions, and it appeared to do a general update first, whereupon I got an error report saying “Error while updating {blank}”. I then got a report saying “Error installing armv7-tvheadend-app-osmc”. I then got an Update message “Operations successfully completed” which seems rather misleading!

Will retry with a clean build.

I am not sure what the custom install may have done, but this is likely why the install failed

Sætter armv7-tvheadend-app-osmc (3.9.0-9) op …
Created symlink from /etc/systemd/system/multi-user.target.wants/tvheadend.service to /lib/systemd/system/tvheadend.service.
Job for tvheadend.service failed. See ‘systemctl status tvheadend.service’ and ‘journalctl -xn’ for details.
dpkg: fejl under behandling af pakken armv7-tvheadend-app-osmc (–configure):
underproces installerede post-installation-script returnerede afslutningsstatus 1
Der opstod fejl under behandlingen:
E: Sub-process /usr/bin/dpkg returned an error code (1)

did a dpkg-reconfigure armv7-tvheadend-app-osmc no help.

first time around the “/etc/systemd/system/multi-user.target.wants/tvheadend.service” was not there after the install did not finish, then did a apt-get remove armv7-tvheadend-app-osmc, and install again… then it was there…???

systemctl status tvheadend.service

root@osmc:/home/osmc# systemctl status tvheadend.service
● tvheadend.service - TVHeadend Server
Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled)
Active: activating (auto-restart) (Result: exit-code) since ons 2015-03-25 10:47:28 CET; 4s ago
Process: 25445 ExecStop=/usr/bin/rm /run/tvheadend.pid (code=exited, status=203/EXEC)
Process: 25436 ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video (code=exited, status=0/SUCCESS)
Main PID: 25437 (code=killed, signal=SEGV)

mar 25 10:47:28 osmc systemd[1]: Unit tvheadend.service entered failed state.

hope this helps…

edit: will try on my second RPI2 wish a fresh osmc