OSMC RC Unable to install TVHEADEND

when I execute that command, I get this:

root@osmc:/usr/src/tvheadend/build.linux# tvheadend -u osmc -g video -C &
[1] 6842
root@osmc:/usr/src/tvheadend/build.linux# bash: tvheadend: command not found

[1]+ Exit 127 tvheadend -u osmc -g video -C

do you know what is wrong?

Nevermind, figured it out, had to exit back to home directory

check your coax cable, it has to be new ones(shielded), the same with the T splitter if you use one.

and it takes tvheadend at least 30 min to maps channel here…
signal on the mux needs to be at least 65%…

and don’t have your tuner near(20 cm) an access point or other wireless devices…

I moved to OpenELEC now and everything runs perfect with TVHeadend.

1 Like

Harry, is there to make TVheadend run automatically at start up without having to ssh to it?

Sorry, nevermind, figured it out here:

http://www.raspberry-projects.com/pi/pi-operating-systems/raspbian/auto-running-programs

I have updated the version of TVHeadend available in the App Store

On initial setup I see

  • The configuration tab
  • No segfault

If you still have a problem let me know:

  • The Pi you are using (1 or 2 / ARMv6 or ARMv7)
  • Tuner you are trying to use

S

1 Like

Have just tried to install the above on my Pi 2 “over the top of” a version compiled in accordance with HarryL’s instructions, and it appeared to do a general update first, whereupon I got an error report saying “Error while updating {blank}”. I then got a report saying “Error installing armv7-tvheadend-app-osmc”. I then got an Update message “Operations successfully completed” which seems rather misleading!

Will retry with a clean build.

I am not sure what the custom install may have done, but this is likely why the install failed
S

Sætter armv7-tvheadend-app-osmc (3.9.0-9) op …
Created symlink from /etc/systemd/system/multi-user.target.wants/tvheadend.service to /lib/systemd/system/tvheadend.service.
Job for tvheadend.service failed. See ‘systemctl status tvheadend.service’ and ‘journalctl -xn’ for details.
dpkg: fejl under behandling af pakken armv7-tvheadend-app-osmc (–configure):
underproces installerede post-installation-script returnerede afslutningsstatus 1
Der opstod fejl under behandlingen:
armv7-tvheadend-app-osmc
E: Sub-process /usr/bin/dpkg returned an error code (1)

did a dpkg-reconfigure armv7-tvheadend-app-osmc no help.

first time around the “/etc/systemd/system/multi-user.target.wants/tvheadend.service” was not there after the install did not finish, then did a apt-get remove armv7-tvheadend-app-osmc, and install again… then it was there…???

systemctl status tvheadend.service

root@osmc:/home/osmc# systemctl status tvheadend.service
● tvheadend.service - TVHeadend Server
Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled)
Active: activating (auto-restart) (Result: exit-code) since ons 2015-03-25 10:47:28 CET; 4s ago
Process: 25445 ExecStop=/usr/bin/rm /run/tvheadend.pid (code=exited, status=203/EXEC)
Process: 25436 ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video (code=exited, status=0/SUCCESS)
Main PID: 25437 (code=killed, signal=SEGV)

mar 25 10:47:28 osmc systemd[1]: Unit tvheadend.service entered failed state.

hope this helps…

edit: will try on my second RPI2 wish a fresh osmc

I would suggest trying on a new image as I am not sure what you changed when you used a different build

Sam

Hi @sam_nazarko

This morning I took a fresh build of OSMC and only installed TVHeadend. I added one mux and it scanned but I am not getting any services found. If I put back the other SD card I have with RaspBMC on it I am getting all the channels.

Sorry to be the bearer of bad news but I am keen to get OSMC working as it looks really good

Keith

just delete/move /home/osmc/.hts the app store installation of tvheadend is doing stuff to that folder… now to check if it scans :wink:

update 1: nope do not scan or work… im back on my own compiled version, that works rightaway… same thing on a fresh install of OSMC…

Just tried a virgin install of RC on my Pi 2 using the RC download image, and after installing Tvheadend server from the App Store I cannot log into x.x.x.x:9981 using either Firefox or IE. However the former gives the message:

“The connection to the server was reset while the page was loading.”

which may help pinpoint the problem.

A few of general comments arising from doing a new installation of OSMC & then Tvheadend Server (using the Confluence skin) :

  1. It is not obvious to me that one needs to click on both “Install” and “Apply”
  2. Clicking on Apply takes you back to the OSMC menu - I would expect it to stay on the TVheadend install page until installation was complete.
  3. Installing something from the App Store always seems to lead to a general update - is this intentional?
  4. There are significant periods when nothing appears to be happening, so one might think it has finished.

Hope these comments help.

clean your browser cache… :wink: that should help

Thanks, that cleared that problem!

However it also is showing no signs of performing a scan - still saying “false” under "initial scan complete on the Muxes page, even though “skip initial scan” is false on the Network page. Unlike the version create with your instructions, HarryL, there does not seem to be a scan command and many other details of the are different.

So it doesn’t look as if the new App Store version for Pi 2 is much better.

Which version did @HarryL build? I must admit that on older versions scanning seemed more intuitive and on newer ones I think scanning is meant to be ‘passive’ but I have had troubles with this.

Sam

from git:
HTS Tvheadend 3.9.2525~g96898a6
march 13 2015.

In my case, and as with most others, I am having no trouble with the scanning (well it says it has completed the initial scan)… the issue is that the initial scan finds no Services. With Raspbmc and Openelec Services are found without issue.

3.9 is not officially tagged in the TVH repo. I will see if I can make contact with the TVH developer today.

Solution for now may be to use 3.6

1 Like

Thanks, Sam.

The Problem is that it is not possible to assign a network to an Adapter. Tried with Tevii S-660 and Sundtek Sky TV Ultimate IV.