OSMC RC Unable to install TVHEADEND

Check if the addon is enabled, sometimes you have to enable it more than once before it sticks

This was it.

But I’m not finished yet :frowning:

Now the “Live TV” menu appears, and it has the channels that I have mapped in TVHeadend, but when I try and view a channel, all I see is a spinning grid of rainbow colored squares. In the TVHeadend “web-page”, in the status tab, it show a connection that is streaming the expected number of kb/s. Could this be because I don’t (yet) have an MPEG2 hardware license?

(I should also mention that it took quite a bit of “trial end error” to get this far. I had to follow withakw’s method of installing TVHeadend from github using HarryL’s instructions, then install and uninstalling the OSMC App Store version, and then running and configuring the github version. I haven’t yet got it running automatically on startup, I manually start TVHeadend on each reboot … one step at a time :slight_smile: )

Do you have audio? Before I installed the MPEG2 codec I had audio but the screen was black. I get the spinning coloured grid when tuned to a radio station. Are you sure it is not a radio station you are tuned to?

No audio. And definitely not a radio station. In the TVHeadend server status page, I can see that its tuned to and streaming the TV channel I selected in OSMC.

@ ObvB - Your comments on having to install both versions has allowed me to move one step on - I created the “/home/osmc/.hts/tvheadend/accesscontrol/1” in DBMandrake’s post above (I had not installed the App Store version). It now scans immediately and finds all the channels I would expect, but I now get the message:

Tvheadend: No free adapter

and on the web page Configuration/DVB Inputs/TV adapters the adapter has disappeared! I assume, therefore that there is something in the file that is wrong for HarryL’s version of Tvheadend, so will take a closer look at that next.

I had the same message initially. I powered down the tv adaptor and rpi and turned on again and it was fine. It thinks the to adaptor is in use.

[quote]Could this be because I don’t (yet) have an MPEG2 hardware license?[\quote]


Turns out there was no audio because I forgot I had the HDMI cable going directly into the TV (which has speakers turned off) rather than the usual configuration where everything goes through the AV receiver :flushed:

So now basic functionality of watching Live TV, and recording and playing back is working,

I still have a coupe of issues :

  • the “Thumbnail” view of the channel isn’t being displayed, (Its working in the Raspian+TVHeadend+Kodi that I set up con the same hardware to compare)
  • The “timeshift” functionality works at first after a reboot, but it soon breaks after pausing TV and/or changing channels. This also happens with Raspian+TVHeadend+Kodi, so it may be something in the build of TVHeadend 3.9.2662~ge4cdd3c

Thanks for the help with all my dumb questions/problems!

I have still not succeeded in getting a TV picture with TvHeadend and my WinTV-HVR-900H, but all seems fine bar a few niggles with a PCTV USB tuner. I suspect it is the firmware for the former generated with

cd /lib/firmware
sudo wget goo.gl/xZSPH -O dvb_firmware.tar.gz
sudo tar -xzf dvb_firmware.tar.gz

which is the problem. Have posted on the Pi forums in case anyone there can help.

I have given TVHeadend in the App Store yet another refresh. Hopefully the configuration tab will be available now.


Starting with a fresh install of RC on a Raspberry Pi 2

I do the updates within OSMC, install the TVHeadend Server from the App Store, install the firmware for 950Q tuner, login to osmc:9981 using user/pw = osmc/osmc and I get stuck here …

When using HarryL’s instructions for building TVHeadend, at this point there is an option to select the standard US ATSC broadcast muxes. It is missing here. This leaves me effectively dead, since even if I knew how to manually create each Mux, I wouldn’t want to do it for every channel.

Edit: I then uninstalled TVHeadend in the App store, and then installed from Github using HarryL’s instructions, and it worked. Previously I think it was necessary to install from Github first, then install/uninstall from App Store … this time it worked installing from Github after the App store.

Yes the latest version of Tvheadend does not have the option to select standard muxes by location. You have to manually enter the muxes… If you select Network Discovery you only need to enter one mux and it will discover the rest. I found the muxes info required after a Google search for my nearest transmitter here in the uk.

With the original AppStore version I could get it to scan the muxes but no services were found. Most others had the same issue… I haven’t tried this latest version as I built Tvheadend according to HarryL’s instructions and all works well.

@psscriven - Your statement “Yes the latest version of Tvheadend does not have the option to select standard muxes by location” surprises me. I thought it was there in the HarryL version, but not at the point that I expected. According to my notes, you select the location when first creating the network, but I think you cannot subsequently amend it without deleting the network and creating a new one. However I have been playing around so long trying to get live TV with two different tuners that my memory may be playing tricks.

I have started to do a clean installation to confirm that my notes are correct, and establish whether all the things I have done in my thrashing around to get things working are really needed. It was then my intention to publish those notes. The arrival of the new App Store version of Tvheadend is an added complication to the process - do I try that first or concentrate on the HarryL version in the first place?

@EMJB For me to get it to work I just did a fresh install and then installed the App store version of TVHeadend and then uninstalled it. I then did the installation following the instructions @HarryL entered and it all started working


Hmmm …

So, trying again … to see if I can make it work without resorting to HarryL instructions …

After installing from the App Store, I get to the configuration tab and I add a network, Type = “ATSC network”, like so …

Then I add a Mux to the network just created like so … (most of the options are greyed out)

And then I set the TV Adaptor to enabled on the network just created …

and then I get this in the system log window …

Not sure if I’m doing something wrong or if its really broken

To set up muxes manually you need to set the frequency, bandwidth, constellation etc, which I am not seeing in your screenshot. This link shows what I see when I configure the muxes. It may not be the same version but I enter the data as shown in the mux window.

I can not recall if with HarryL’s version I could just select the transmitter by location or if I entered the mux data… I am away at the moment so I can not check

@ObvB, in the tab where you set the TV Adaptor go up one folder to the Auvitek AU8522 QAM/8VSB Frontend folder and look if you have to/can add parameters there. I seem to remember having to do that in the latestversion of tvheadend as I was seeing the same log error you had.

At the moment I’m using Version 3.6, which is included if you clone tvheadend from github.com and compile it.

If you use the Tvheadend Network discovery option, you seem to get the frequencies for all the muxes associated with that station including its satellites. I my case (UK-Sudbury) that means you get half a dozen or so on which the scan fails, which is rather worrying till you cotton on and delete them.

The HD mux is included using either method, and the scan on that will also fail if you have an SD only tuner.

One area of concern is that you pick up the same channels from two muxes (e.g. if you are on the edge of a satellite Tx area). This has caused many problems for users of Topfield PVRs. Is Tvheadend clever enough to associate the two copies of one channel, and pick the one with the better signal?

Just tried the new App Store version of Tvheadend on my Pi 2 on a clean build, and:

  • Using IE I don’t see a configuration tab
  • Using Firefox I get the “The connection to the server was reset while the page was loading.” even after clearing the cache.

It is showing as HTS Tvheadend v.39~osmc on IE, so presumably really is the new version.

Is anyone else seeing these problems?

P.S. Have just uninstalled Firefox and re-installed it, and am still getting the same message.
P.P.S. Still getting that messages after PC reboot

The only thing that I can change in the level(s) above is the name, which doesn’t effect anything but the name!

I’m now having a similar problem. I didn’t clear my entire cache, but did try to delete all history for the osmc server, but still was getting errors loading the page.

What did work is opening an “New Private Window”. Using Chrome also loads the configuration tab.

Edit: I did try enabling the TV adapter and assigning the ATSC network before creating the Mux, but still there is nowhere to enter details for the mux (frequencies or whatever) and still getting the same error in the system log

Apr 04 18:33:07.570 mpegts: 0 - starting for ‘initial scan’ (weight 1)
Apr 04 18:33:07.570 mpegts: 0 - tuning on /dev/dvb/adapter0/frontend0
Apr 04 18:33:10.112 linuxdvb: /dev/dvb/adapter0/frontend0 - failed to tune [e=Invalid argument]
Apr 04 18:33:10.112 mpegts: 0 - failed to start, try another