OSMC [RC] wireless not working - SOLVED


I did a new install of RC and set wireless settings (router, password, etc).
But when the OSMC installation was finished, OSMC came up, but
the dongle never lit up, and the wifi never started.

So, I connected via the ethernet wired connection.
Then in OSMC settings, I enabled the wireless adaptor,
selected my SSID, entered password.

Then the wifi started, and now it’s working perfectly (as before with Alpha4)

So, it seems that setting the wireless settings during the install
does not work in RC. It was working very well in Alpha4.


It does work, however it only makes one attempt to connect on the first boot.

If for any reason the first attempt to connect fails it does not try again. There are many different possible reasons why wifi might not connect on the first attempt including interference or a weak signal.

Being able to configure wireless from the installer is really only there for those people who don’t have access to a remote that works out of the box, CEC, or a keyboard. Otherwise you’re best to just use the network settings page to set up your wireless.

I don’t see why it would not work on first attempt at first boot.
And then work (effortlessly) on the first attempt in the settings.

Also, remember this was flawless in Alpha4, with identical configuration.
I did it several times with new install, and wireless came up first time every time.

With RC, nothing has changed regarding my HW, router, interference, weak signal, etc., etc.
And I never even saw the dongle light go on.

If it did try and fail on the first attempt on boot, then it would be helpful to
indicate this with a message on screen.


just came across this article and wondered whether the current version of OSMC (Jan 2016) works in the same way i.e if it fails to connect wirelessly first time it does not retry ?

It works fine here at home connecting automatically, but when i take it to a friends house even though I have configured and used their wireless network in the past I see sometimes (not always!) I have to go through and connect it manually. Based on the previous post It sounds like its simply failed to connect first time for whatever reason (weak signal, momentary drop in connection, reboot of router or switching router on AFTER starting raspberry Pi2.

So is there anything on the horizon for an auto scan of available (previously successfully connected) networks say every 1 minute ?

I can not replicate your issue. For me wireless on OSMC automatically reconnect even after a router reboot or other loss of signal.

Actually I believe you misunderstood the communication in this thread. The discussion was about the initial connection to wireless as part of the installer. Not about reconnecting to a properly configured wifi outside of the Installer process.

OK. Thanks for that.
Is there a log anywhere of connection attempts and possible failures, etc

Should be with sudo journalctl -u connman.service

when i run that command it shows up a file showing yesterday’s log entries.

not sure how to move around in the journal plus why is it only going as far back as yesterday only?