OSMC RC3 Install (from raspmbc)

Hi,
After using raspmbc for a long time I decided to give the RC3 a go.

With the default skin I can’t see any scroll bars for moving about? It seems that right click moves back - is that right?

Is it possible to use a skin that has scroll bars and back buttons?

I am having a real problem trying to set up my video files again - it doesn’t seem to want to allow me to click on Videos/Files and set up as before. What should be the process now for adding the external media?

Thanks

Nick

p.s. the new installer is very impressive!

Please try using the Updates function to download the latest updates - which includes an overhaul to the skin. The version of the skin that shipped in RC3 is not mouse compatible.

Nice! That worked ; it is easier to use. I have noticed a few things:

  1. The ‘Set content type’ on USB folders sometimes isn’t appearing - I’m not sure why.

  2. It might be useful after initial installation to force a manual update to avoid this?

  3. Is SSH enabled? It might be useful during installation to have an ‘advanced’ section where I can upload my SSH key?

  4. Is there a way of configuring the movies panel to show all movies without the genre (etc) meta info? i.e. so just a set of images/titles?

Thanks

Nick

Not sure what you mean by that - you set content type when you add a source to the library, you can’t set content type on just a folder in the file viewer. (Videos)

RC3 is still a release candidate so things are still in flux a bit - the updated Skin will be part of the final release.

Yes, ssh is enabled by default, username and password is osmc.

Not sure whether you’re suggesting that uploading keys should be in the installer that creates the SD card image, or in the walkthrough that runs after installation ?

In any case it’s a bit of niche/power user feature to use ssh keys (given the target audience of OSMC as a mediacenter OS) so it seems unlikely to be added as part of the install process.

For a power user who wants to use ssh keys its a simple (for a power user) matter of logging in with password authentication the first time to paste in your key, or use something like scp to upload your keys and then optionally disable password based authentication.

Don’t know the answer to that one sorry, as I don’t use the OSMC skin myself except briefly during testing.

You can do this after this commit gets built and included in to the images: https://github.com/samnazarko/osmc/commit/6922493e92b67769af401979e4ae18fbabfe5ab7

The post-inst script does not guarantee network availability, you’ll have to verify that yourself.

Sam

@sam_nazarko, would you mind explaining how this post installation script works?

Am I correct in thinking that it is now possible to have customisation commands run immediately after updates have installed, every time updates are installed?

Edit: Or is this only specific to one particular package?

If you add a bash script called postinst.sh, it will run on the first boot

Sam

@sam_nazarko : thats neat ! I do agree with @DBMandrake that adding an advanced section in the GUI might be overcomplicating and its easy enough to use ssh-copy-id to install my keys.

I’ll have to have a bit more of an investigation on this. So you’re saying in order to set a content type, I can’t go in through “Videos/Files” but need to go through add video source ? confused

I understand. Thinking on how Fedora does it, it installs and immediately does an update check - perhaps that might be worth considering?

Great, thanks - knowing the username/password is sufficient to set it up.

I’ve managed to get it to display the icons by changing the type.

My eSynic remote (http://www.amazon.co.uk/eSynic®-Wireless-Keyboard-Touchpad-Mouse/dp/B00DUUF30Y) worked out of the box which is great … although annoyingly in the latest update the mouse pointer has disappeared :frowning:
( x-ref: remote thread OSMC Remote Support - #51 by papatzas )

“which includes an overhaul to the skin. The version of the skin that shipped in RC3 is not mouse compatible.”

Is it possible to go back to the original rc3 skin?