Osmc recordings location

Running OSMC 17.1 on a RPi3 with a USB disc drive and a PCTV 292e stick, TVHeadend and Samba.
It seems that I can record, but my first recordings ended up on a path /media/WD150GUSB (so my usb disc) but later recordings have ended up in /mnt/recordings. And I have no idea why!

From my OSMC player I can navigate to WD150GUSB and see my older recordings, but I can’t navigate to the /mnt/recordings stuff.
I can get to both by logging on via SSH and looking at the file system.
I have the WD150GUSB drive showing up as a Samba share across the network, and I tried adding /mnt/recordings as a network share, but that hasn’t worked.

How do I get all my recordings into the right place so I can access them?

Can you see /mnt/recordings if you add it as a source?

No it doesn’t show up at all.

Having a few thoughts about the issue. I had to re-install OSMC and I suspect the recordings in /media/WD150GUSB may have been made with my initial configuration.
So I am now wondering if, when I reinstalled OSMC (and TVHeadend) if I messed up (or ignored?) a location???
I had a look at the GUI on the TV interface, but didn’t see a way to re-configure TV Headend, but it does mention the web interface. I haven’t looked at that yet to see what I can do about paths …

Alternatively, the GUI offers me the option of uninstalling TVHeadend - maybe that could be a route?

Any advice would be appreciated

Typically you can reach the TVheadend Web GUI at

http://< ip or DNS name of your OSMC device>:9981/

There look at Configuration -> Recording -> Digital Video Recorder Profiles -> Recording System Path; probably you only have the default profile configured till now.

Aha - looks like you have hit the nail on the head!!
In the web interface under “Parameters” it shows the Recording system path as /mnt/recordings.

So can I just change that, and do a reboot?
Fingers crossed …

I’m confident …

Trying a recording now - it is 30 minutes. I will let it run and then check …

Woo hoo - it worked! Thank you VERY much.

Have fun with OSMC. :wink: