Osmc refused to play music or video or any content of addons

Sorry, if solved but I could not find a similar problem/solution so fare in the forum.
I used to have a pi2+ with osmc on a DENON-Reveiver via HDMI together with a TV. Running well.
Updated with OSMC to a Pi4. Running well.
I see Kodi-GUI on TV, can use TV-Remote to navigate in Kodi, can play music from Kodi via Receiver-Speakers, can play videos to the TV.

My problem today: can navigate via TV-Remote in Kodi-GUI, can “click” on music-files or videos or to content of any add-on. But the player does not start the file.
Logged in via ssh and did a apt update and dist-upgrade

Uploaded the log: https://paste.osmc.tv/dayuvosohe

I did a reset of the Denon-Receiver 2 weeks ago and am not sure if I tested OSMC since.
But as I can see the Kodi-GUI on TV, hear the “click”-sound and “wusch”-sound of the GUI via the Receiver-Speakers while navigating through the kodi-menues with the TV-Remotecontrol , I’m quite sure that it is no HDMI-Cable-issue. Any Idea what I can do to solve that?

Is it just UPnP content not playing? Does content located on the connected drive play?

Local content, audio-files ( like *.mp3) and also video-files on USB-HD do not play.
And streaming-Content does not play.

The one thing in the logs that I see that you tried to play it looks like it is trying to use your TV as the player. I’m not super familiar with UPnP but maybe it remembered the last player you were using. Not really sure. I would try either doing a context menu>play using>video player or just turn off external players in the UPnP settings, reboot, and then see how you get on.

Tried: doing a context menu>play using>video player
I see:
Philips TV
worked with PAPlayer and VideoPlayer as expected.
If I choose PhilipsTV it starts the UPnP thing and the TV streams the sound.
(At leased it does play something with any “player”.)

How do I manage to make that working via a simple click again?
I turned off UPnP in settings and rebooted.
Now the simple click starts the audio as it should.

Switching on UPnP again might shoot me in the kney again later, or what to expect?

I honestly have no clue how that TV would be playing by default without you going out of your way to purposely change it outside of the GUI. But even more confusing is that the logs show that your default audio and video players are the normal ones.

hmmm? … I did never change things outside of the Kodi-GUI on the Pi4.
But I think I have connected the PI-HDMI directly to the TV-HDMI-in weeks ago to do a quick test in bypassing the Denon-receiver. That might have start confusing the Kodi-config.

For a test I switched UPnP-Support on again in the Kodi-Settings, and got the same problem I started the post with.
But doing a UPnP-Service off-reboot-on-reboot twice again now, kodi keeps working just fine as if never been a play-problem. … What the heck is that?

It’s working now with UPnP player support turned on now?

I’ve never heard of this issue and I don’t remember ever seeing where Kodi had the ability to use UPnP as a default player without making a custom playercorefactory.xml or advancedsettings.xml file. You don’t have either of those files and your default players are paplayer and videoplayer which is what they should be. All this shows in your logs as it being how it should be… except the part where it is playing to upnp without you telling it to. I tried to reproduce to doing a few rounds of playing to my TV via UPnP but it will only do it if I tell it to “play using” every time.

Yes, it’s working now again with UPnP/DLNA switched on.
But I disabled the sub-point “search for UPnP-Players”, which previously was anabled.
The “play with”-option “Philips TV” is gone.
If I remember right, I have seen a file playercorefactory.xml in an ssh-session while looking in ~/.kodi/userdata/ . But I clearly did not “create” that file by myself. And that file is actually also not there anymore.
My TV is connected to my LAN, as well as the Pi.
Pi and TV are also connected to the Denon AVR via HDMI. The TV-Audio-out setting is set to “always send to the DENON AVR if the DENON is on”.

And yes, everything works fine this morning again (local audio-files, local video-files as well as youtube-addon and all other streaming-addons) even with UPnP/DLNA enabled.

Thank you very much for your very quick, very kind and very professional support!
The OSMC-support is awesome!

1 Like