OSMC Release Candidate 2 is here

Thanks Sam… RC2 as landed in Lisbon
For me RC1 was already stable enough for my minimal settings.

Enjoy and let us know if you have any troubles

S

Thanks. No troubles updating manually but scheduled updating does not appear to work. Maybe this release fixes the issue.
Scheduled Updates

Awesome. Been waiting for Kodi 14.2 for the NextPVR add-on fixes. Game of Thrones starts tonight, so I’m not risking updating until tomorrow, but I’ll give it a good work out then.

Thanks a bunch, Sam.

Hi Bryan

We are aware of this issue but I was reluctant to push it to the release until it was underwritten by the QA team. We will deliver it as an update once it passes shortly

S

this issue still persist in RC2

Nobody replied. Im just trying to help.

We are aware of this internally

S

RC1 > RC2 update worked fine for me on RPi2.

Keep up the good work!

Now my library is loaded at startup in WIFI :slight_smile: because I can wait for the connection.

The second bug I have in RC1 is not fixed in RC2. The TVHeadend package for RPI2 doesn’t work. I can’t select my dvb-t device. There is an icon directory for my device while it is a tuner icon when I compile TVH myself. When I want to add a newtwork, I can’t select the provider to add muxes automatically. Please tell me if you need logs.

Thanks for your good job :smile:

1 Like

Thanks Sam, Good work.

So far, so good. No problems. Never had problems with your distros since raspbmc.

Having trouble getting in to the remotes section in My OSMC in RC 2. Clicking it does nothing. Works fine in RC 1 though

Apart from that no issues, running fantastically! :smile:

Please enable debug mode in Kodi, then after going to the remote settings unsuccessfully, use the log uploader to upload your Kodi log. Thanks.

How can I know if my system update automaticaly? I’m not in front of my tv, I’m out of my home, but control it via telnet.

cat /etc/os-release

should show

Release Candidate Two

Sam

Same issue as spudy12… Can’t get into Remotes. Was fine with RC1.

Updated to RC2 from RC1 without problems. But I still have issues while trying to setup LAN (IPTV) + Wifi (internet) connections simultaneously. I can configure both networks in settings, I add IPTV routes with sudo route add, and everything seems to work.

Then I try to manually restart RPI 2, OSMC is now connected only to LAN, Wifi is not connected. When I go to WiFi list in OSMC settings my Wifi network is not on first position in list. Is it possible that it tries to connect different wireless network (not mine) and this fails?

When I repeat manual setup everything works until next restart. Do you have any suggestions?

Once we get a log I am sure we can address this

S

I have been waiting for others to report problems with WiFi/samba now with RC2 but seems like i am alone.

RC1 let me look at movies with fails every 20 minutes.
But as someone more said, i felt like one update made it stable to allow me look at whole movies.

  • answer he got was that no updates existed and placebo affect.
    (I do manual updatecheck every time)

Now with RC2 i am back to the point where all movies fail more often then ever.

With RC1, when movies failed after 20 minutes i choose to restart OSMC it thru the menu.
But now with RC2 i often cant, i have to cut the power.

And about menus. Every first thing i do is quick, but lets say i update or something, I am back to slow handling the next operation. I have to wait one minute before something happens. So every move i do i end with a restart to get quick responds again.

I have a thinking that it is samba, not WiFi. I can stream TV channels without these fails.
Or a memory buffer thing.

I upload logs ever time it happens.
And i use:

  • Raspberry Pi 2.
  • Router: Asus RT-N66U
  • Wifi: Edimax EW-7612UAn V2
  • Real 2.4A power
  • sandisk ultra 8gb class10 + sandisk extreme usb 3.0 16gb
  • wireless keyboard

Unfortunately this is the way connman is supposed to work. Please see the following post: