OSMC Remote (context) menu button issue

Hello all.
I’ve got a bit of a problem with my OSMC remote - the (context) menu button no longer works. The button I’m referring to is the “hamburger” style button as shown on the remote in the OSMC store.
I’ve got a 4K+ and an older 4K and weirdly the menu button works on the 4K remote.
I’ve tried the Kodi iOS remote and that works on the 4K+ fine.
I realise that now we need to long press the button for it to work…
Here is a copy of my logs: https://paste.osmc.tv/izaxudenez.
Any help would be appreciated.

I’m not seeing anything obviously wrong in those logs. I also don’t see any handlekey events showing that button being pressed either. Does the light on the remote flash when you push that button? Have you tried changing the battery?

Hi, yep, the blue light flashes on the front of the remote. All the other buttons work fine, so I haven’t replaced the battery yet…

Just to clarify, the light flashes when you press the menu button normally but Kodi does not receive the command? If you hold down the menu button the light flashes but Kodi does receive the command? Can you plug the dongle into a PC and open a word processor and see what happens when you press the menu button.

The light flashes when I press the menu button and it stays on if I hold the menu button down. Kodi doesn’t respond to either press. To eliminate the battery, I’ve just replaced it and there is no change. I used a bit of software to read the raw input from the dongle on my windows laptop and nothing is received when I press the menu button. I found one of my spare remotes and fitted the same new battery and resynced it to the dongle. Using the same software, the menu button is picked up as a “C” on the spare remote. Menu button and command works fine on Kodi on the spare remote. Thanks for your help, I suspect the remote is faulty so it’s a good thing I’ve got a spare.

1 Like

Is it a short flash (same duration as other buttons that work, or a long one).
If the remote is faulty and in warranty please start a support ticket so we can replace this.

Neither a short or long press (flash) works on the faulty remote.
Don’t worry about it Sam, I’ve got four remotes in total bought between 2017 & 2019 (separately and/or with a 4K/4K+), and I’ve got no idea which order the faulty one was bought on.
I’ve binned it an back up and running with my spare.