OSMC Remote Control + macOS + Kodi issue


#1

Hi,

I have just bought and received an “OSMC Remote Control” from Amazon. The goal is to use it on a Mac Mini running Kodi. Unfortunately, I’m hitting an issue.

Both the Mac Mini and Kodi are running their latest versions. To be more specific, the Mac Mini is running macOS Mojave 10.14.1; Kodi was running the stable 17.6 Krypton version, but I’ve also upgraded to 18.0 Leia beta 5 and the issue remains.

My issue is that all buttons appear to work fine, except the back button (which is a bit frustrating because you can only ever go forward and never back :slight_smile:).

When I press the button, if I look at the front of the remote, I do see the blue light turn on briefly.

I have put Kodi in debug mode, and when I press that particular button, nothing at all gets logged. In contrast, when I press any of the other buttons, something like this gets logged:

18:50:37.679 T:4903265728 DEBUG: Keyboard: scancode: 0x7d, sym: 0x0112, unicode: 0xf701, modifier: 0x0
18:50:37.679 T:4903265728 DEBUG: HandleKey: down (0xf081) pressed, action is Down
18:50:37.680 T:123145312260096 DEBUG: Thread JobWorker start, auto delete: true
18:50:37.684 T:4903265728 DEBUG: ------ Window Deinit (Pointer.xml) ------
18:50:37.689 T:4903265728 DEBUG: Keyboard: scancode: 0x7d, sym: 0x0112, unicode: 0x0000, modifier: 0x0

I have read there are multiple versions of the remote, mine is the one with the volume up/volume down keys, which I believe is the newest.

I have tried to download the Kodi add-on to remap keys, but when I try to remap the back function, and I’m asked to press a key, nothing is detected when I press the remote button on the remote.

Is this a defective remote?

Thanks!


#2

Hi,

Let me grab a Mojave machine and test.


#3

Hi,

You do indeed have the latest remote.

The remote functions as both a keyboard and mouse. It seems that there have been some changes with Mojave that hinder the back button’s functionality.

I’ve done some testing on my machine:

Installing USB Overdrive (it’s free) should do the trick temporarily. It detected the Back button out of the box and started sending events to Kodi.

I don’t know enough about macOS to advise if this can be done in System Settings without additional software. The key isn’t being remapped, it just seems that it wasn’t being registered beforehand.

Sam


#4

WOW, I am impressed by how fast you replied!

I got it to work with USB Overdrive.

For the record, I didn’t know this app/driver existed, so I’m not sure if I configured it correctly (although the back button now works correctly in Kodi).

Within the app, I pressed the Back button on my remote, this has added ‘Back’ under ‘Any Mouse, Any application’.

Originally, this mapped by default to ‘Keyboard Shortcuts’->‘Back’. However, this didn’t work in Kodi. Debug logs were showing a key was pressed, but Kodi didn’t know what to do about it.

I then changed the mapping to ‘Press Key’->‘esc’. And this worked in Kodi.

Did I do it right?


#5

That will work. Esc I think always takes you home, Back takes you up one layer.