OSMC Remote doesn´t work any more

Hi I´ve ordered (#28158) a OSMC remote control to control a HTPC. Unfortunately it seems to stop working. The batterie is good. I also get a message that “USB Keyboard Mouse” is installed & ready if I plug in the transmitter. But I can´t control e.g. Kodi with the remote. Also the remote doesn´t work plug&play with the Vero4K. I don´t know, what should I do now?

1 Like
  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

Unfortunately it doesn´t pair after I plug in the USB receiver. The blue LED is fixed on but it doesn´t blink 3 times.

Can you change the battery?

Thanks a lot, now it works. The trick was to remove the battery (~10 Minutes). After that I followed your pairing guide. During pairing I had to wait about 30 seconds (not 5 seconds) but than the blue led from the remote flashed 3x quick. Now it works. :slightly_smiling_face:

That suggests to me that your battery is getting quite low.

Hi it only worked one time. Now it doesn´t work at all. I´ve put a new battery in, the pairing (3xflash) only works after 50 seconds. But after off/on from the Vero4K+ the remote doesn´t work at all. I think it´s defect. Please tell me the adress where to send it then you can have a look at it.

Do you still see a blue light when you press a button?


Please start a support request with order details.

Did you try the App remote control? The official kodi app is ok called Kore. The other one is better called Yatse. I also use a separate app to control my Samsung TV, there is also another app for my AVR but I don’t use it.

Hi I´ve made a ticket and answered 2020-03-25 12:20:39 but the ticket status is still open and my problem isn´t solved. Could somebody from the support team please look at this ticket? I made logs and uploaded them. Thanks, Michael.

I will check this for you shortly.

I’ve updated the ticket with some details


Could anybody from the support team have a look at my ticket, please? It´s still open and I want to reuse the Vero4K+ hardware as soon as possible. In fact I´m trying to get this remote control to work since 1 month ago.

Hi Michael – I already shipped you a new one last week.
I’m keeping the ticket open until you confirm that it is working.

Hi the new remote is here and working flawless. Thanks a lot. Now I can use my Vero4K+ again.
Should I send you the defectice remote to you or can I throw it away?

Please just recycle it responsibly. I am glad this is resolved.