OSMC Remote key stuck behaviour

Every 10 minutes or so of using the OSMC remote, the kodi repeats indefinitely the last keypress, like it was stuck. I didn’t wait it more than 20-30 seconds before pressing any other key.

The behaviour doesn’t seems to depend on hdmi output (TV, projector), room (reflexion surfaces), plugins installed, key pressed (left, down, back, ok), skin (osmc,confluence), menu (home screen, settings, movies, playing movie {pause/play/pause/play…}). It can be “unstucked” by pressing any other key, not necessarily the stucked one.

It happens with all the updates from the last month, including the 3.10.101-1 kernel.

The file /lib/systemd/system/eventlircd.service has the line
Before = mediacenter.service
as suggested in Strange Remote Behaviour After Latest Update - #3 by DBMandrake

I can’t reproduce with debug enabled.
Any advice?

This kernel hasn’t been made public yet, it’s very much recommended for testing only now.

Is anything else connected to the USB? Does removing it help?


This behaviour was present with the official packages too.
I’ll keep the 3.10.101-1 kernel, because the LED fix is more important.

Only the remote adapter is connected to USB.

I’ve started eventlircd with -vvv, but it doesn’t log events (journalctl -u eventlircd). The process is quiet after “event output device” is created.

The issue is very hard for me to replicate on my Vero, but it does happen. I am aware the problem persists on the 3.10-101 kernel.

It happens if a USB packet is lost. Until the next packet is received from the remote, it keeps sending the remote press.

I am aware of the problem and I am looking at a way to resolve this. This used to affect the Raspberry Pi, which uses the same USB block (dwc_otg). It’s being worked on.


Did you tried to reproduce it with http://www.yoctopuce.com/tmp/debug_libusb.zip ?
Is the link from USB Packet loss · Issue #19 · raspberrypi/firmware · GitHub
I’ve changed vendor id and product id but didn’t worked

Search for Yoctopuce devices with debug firmware
4 USB devices found
device 2252:1037
Use device 2252:1037
try to get serial for 2252:1037:0
----Running Dev 2252:1037:0:     ---
Check that the kernel has no lock the device
         need to detach kernel driver
Claim interface of 
Get Active Configuration
endpoint 81 size=8 
Drop any packet of potential previous run
we have drop 0 packets
Test a burst of 0x1000 packet form 0x3 to 0x1003
Send start to the device
libusb: error [submit_bulk_transfer] submiturb failed error -1 errno=2

I’m not even sure if 2252:1037 is the right device, but lsusb only shows:

Bus 001 Device 003: ID 2252:1037  
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The issue is 4 years old. I’m not sure is worth waiting for…

How do I add kernel parameters? I want to try
dwc_otg.lpm_enable=0 dwc_otg.speed=1
as described in

After installing the 3.10.101-5 kernel, I can’t reproduce the issue.

The apt history shows:

apt-get install make gcc libc6-dev libusb-1.0-0-dev libusb-dev usbutils
apt-get purge libusb-dev

I’ve built the libusb_sync

apt-get purge make gcc libusb-1.0-0-dev libc6-dev
apt-get autoremove
apt-get install vero2-image-3.10.101-5-osmc

It hanged. I had to remove the power source. And now, with usbutils and the new kernel I can’t reproduce the issue. It may not be a good thing :slight_smile: . I didn’t reproduce the issue neither with debug enabled from kodi interface.

It still happens.

I meant that the issue has been solved for Pi. We need to work on improving it for Vero 2 which uses the same USB block.

Yes – I find it extremely hard to replicate. I’ve only experienced it once and I watch on my Vero 2 as my main viewing device.

Nonetheless, it’s being worked on.