OSMC Remote spamming


I’ve been having an issue with my OSMC remote recently where pressing a button would continuously do that action on my Pi until another button is pressed or I remove the USB receiver. I have also noticed that the blue light on the remote is not continously on when the buttons get “stuck”.
I’m using a Raspberry Pi 3, and have the November 2019 (20191118 image) version installed via clean install on a new micro-sd card. The issue was also present during the initial setup screen too.

Logs: https://paste.osmc.tv/jinevaqewa

Is my USB dongle or remote faulty?



Are any other USB devices attached?

How is the Pi powered?

Have you tried changing the remote battery?

No other USB devices are attached.

I’ve tried changing the battery to a new Panasonic CR2032 cell and the same thing happened.

And for the PSU I’m using a Powerpax SW4600-UK (5.1V 2.5A) to power the Pi. I also tried using a Raspberry Pi branded DSA-13PFC-05 FUK PSU (also 5.1V and 2.5A) and the same thing happened.

Thanks for confirming.

I would put the receiver in another port and re-pair the remote.

So I’ve tried re-pairing the device several time and all the ports on my Raspberry Pi, and the same thing happens every time. I’ve also noticed that pressing any of the arrow keys and the home button causes the spam to happen (as if the key is physically stuck), but pressing the Info button stops it.

Usually that would mean that the release of the key is not registered. This is typically caused by high congestion on the USB, which is why I asked if you had any devices attached

Can you reproduce with debug logging enabled?

So I enabled debug logging, and this is the output when I was pressing the buttons on the remote: https://paste.osmc.tv/emuligapap

I was not holding any of the buttons on the remote down during the debug log, only pressing them once.

Your repeats (for example the Info button) seems to be coming from CEC, not the OSMC remote.

Here is another log: https://paste.osmc.tv/qihizuhixe
This time I rebooted the Pi and disabled CEC on the TV when the Pi was booting back up. I did have to re-enable CEC so I could upload the logs though, which is why there are a few CEC commands in the log file. I had to do the same with the previous log too.

I was also monitoring the log file as well with tail -F, and I was getting heavy repeating spam from the remote for every button until I physically removed the dongle from the Pi.

I have also done some testing on my PC as well within notepad, and pressing any of the direction buttons twice cause the cursor to move continuously in that direction - basically the same behavior I was experiencing on the Pi running osmc.

Could there be something (dirt/liquid) that blocks the keys from returning into neutral position?

In this case you best start a support request to start the RMA procedure


A post was split to a new topic: Rii MX3 Pro remote