OSMC remote stopped working

Hello wise people.

Please can someone point me in the right direction. My OSMC remote has just stopped working, it was perfect until about 2 weeks ago. I’m not sure if it’s something I can fix or if it’s hardware?

I have a rasberry pi 3 running osmc – 2017.07-1 Linux 4.9.29-9-osmc
I have SSH’d in and run “sudo apt-get update” and then “sudo apt-get dist-upgrade”

I have this remote OSMC Remote Control - OSMC

I have searched and searched but I can’t find any existing thread that solve my problem. I have install lsusb and can see (I think) “C_CONNECT power” popping up when I plug in the receiver.

I’m not sure how to do a full dump, but I think this is my receiver:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 9 Hub
bDeviceSubClass 0 Unused
bDeviceProtocol 1 Single TT
bMaxPacketSize0 64
idVendor 0x1d6b Linux Foundation
idProduct 0x0002 2.0 root hub
bcdDevice 4.09
iManufacturer 3 Linux 4.9.29-9-osmc dwc_otg_hcd
iProduct 2 DWC OTG Controller
iSerial 1 3f980000.usb
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 25
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 0mA

Dmesg gives me a wild amount of data, not sure what I’m looking for there.

Anyone have any ideas?



Receiver looks like it’s being detected just fine. Good stuff.

How long have you had the remote?
Do you see a blue flash on the remote when you press a button?

I hate to ask this, but a lot of enquiries we get are due to this: but have you tried changing the battery?


Hey Sam,

Thanks for getting back to me so quickly. Please don’t apologize, assume I’m a fool :slight_smile: I’m really hoping this is something stupid I have done and it’s easy to fix. Glad to hear the receiver is still working, I was convinced that where the problem was.

I have had the remote for about 4 months. Was working perfectly, I went away for the weekend and when it came back it just stopped. I thought maybe an automatic update for OSMC broke it, but that doesn’t seem to be the case.

I have tried 2 different batteries and am getting a good solid blue dot. If I press buttons wildly sometimes they are quick, sometimes the blue light lasts for about a second. I read somewhere that maybe it needs to be re-matched with the receiver. I can’t find that original thread, I thought I followed the instructions to do that, but it didn’t help. Happy to try again if you think that might work?


If the remote is paired with the dongle, and the dongle is running
properly, it’ll be a fast blue flash.

If you get a long pulse, the remote is unable to find a paired dongle. They sometimes fall out of sync when they’re not used for a period of time, and that sounds exactly like what’s happened here.

Try this:

  • Remove the USB from Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Pi for 2 minutes. Turn it back on. The remote should now work

Thanks Sam, I just tried that now (twice) but it didn’t work.

When I hold Home and OK for 5 seconds, it doesn’t flash. It gives a solid blue dot. That tell you anything?

The issue may be the remote misbehaving then rather than the dongle
needing a resync.

The solid blue dot means it’s searching for a receiver to pair with. At this point, you
should plug the receiver in to the Pi (when it’s on).

After a while, the receiver should pair with the remote and button presses should show
a short flash on the remote.

If this doesn’t work send an email to sales@osmc.tv and we’ll get
this resolved for you