OSMC Remote Support

I’ve just install OSMC Alpha 1 on RPI (Ubuntu installer) and so far it seems pretty solid, however my original XBox DVD remote that was working fine on the latest Raspbmc (same RPI) is not functional. I’m assuming that support will appear in a future release but thought I should mention it. Wireless keyboard works great so not a short term issue.

Mike

Tried with a XBOX remote and get absolutely nothing. Using my Harmony remote the RPi does respond but only after a long key press. Other than this looking good.

Remote support is not in yet, please see the release notes on the OSMC blog.

Hi @sam_nazarko , I’ve been using a acer RC6 ir remote for Raspbmc and openelec without any hassles. With OSMC all that works properly is the arrow buttons. I am unable to make menu selections etc. Looking forward to more remote support. Also great job with OSMC. I will be happy to test any remote support.

It’s an RC6 remote so it will work once we get eventlircd up

Cheers

If I enable Infrared support in OSMC Settings program. My remote wont work. It’s a rc6 xbox remote. With raspbmc it did work. Am I forgetting something or is this feature not implemented yet. In Raspbmc you could select the remote from the menu, I am missing this option right now.

This feature has not been added yet

I just installed Alpha 4 and I too have a RC6 and it is still not working. I did a quick search of the website and found https://osmc.tv/2015/02/osmc-alpha-4-is-here/ where the documentation says that "most"remotes are supported. Is this simply referring to Kodi?

Apologies for not being clear:

  • GPIO remote is not implemented at all yet
  • RC6 remotes are implemented, but do not appear to be working due to some issues with LIRC that we are still tracking down

S

Hi All,

Firstly, great job on osmc. Alpha 2 was a little flakey when i tried but alpha 4 on pi2 is rock solid!
Amazing work!
Having an issue with this remote

I now have multiple pi’s and have one of the old mce remotes which works fine on osmc alpha 4 build but the remote stated above does not work.
When running lsusb, it appears as 0755:2626 Aureal Semiconductor and i have tried copying over the .ko file from the old builds.
HAve tried following these instructions
http://www.openmediacentre.com.au/tutorials/media-centre-hardware/m350-media-centre/wireless-multimedia-infrared-ir-remote-controller-deal-extreme-34435/
but when i try ot make it says there’s in error in the ‘recipe’.
Intergration of this remote in next build would be great but would more like to know the steps for resolving the issue.
Been playing with linux for a while thanks to Sam’s work on his distro’s but not at the level of understanding the process of compiling and installing modules/kernals.

Any help greatly appreciated.

Cheers,
Chris Nelson

Hi all,

bring up osmc on rasp pi 2 yesterday morning. every thing works except the infrared controller
been reading a few on osmc website. so it’s seems that there’s some problems of integration
of sw modules that interfaces with the IR receiver ?

+1 to @superpigeon2000 , i have exactly the same cheap controller, works out of the box on raspbmc+ pi1,
nothing on osmc + pi2.
on the receiver there’s a red led that flashes when it receives a command from the remote
on osmc , the led stays down => the module is not intalled so maybe even not powered.

a question to @sam_nazarko : the conversation was about alpha. I use the RC. is it the same status ?
do you plan to integrate this module quickly or is it postponed to later times ?
if you want a beta tester, i can be this one … also could give some extra infos (dmesg log and things like that)

thank you for your work… it’s great

+1, same issue here

Just a quick update. Original XBox DVD remote is still not working with OSMC RC.

Mike

We need more info, how did you try and enable it?

Sam

Truthfully Sam I didn’t do anything. This remote worked out-of-the-box with Raspbmc (one of the many things I liked about Raspbmc) so I just assumed that this would be the case with OSMC.

Mike

I think you would need to:

Update OSMC to the latest version as we’ve moved on a bit from RC

Go to My OSMC -> Remotes and select the XBox Remote

Sam

I have a problem with Logitech UltraX Media Remote. Seems to work properly but the “Enter” key don’t work.
It work fine with RASPBMC.
Thx

I updated to latest via MyOSMC then selected the XBox remote as you suggested but still no joy. I can see in /etc/lirc that lircd.conf is now a symbolic link to xbox-lircd.conf but the remote is still not working even after a reboot. Currently have the hardware plugged into another Pi running Raspbmc and it’s working fine. Don’t know if it makes a difference but OSMC is running on a Pi 2.

Mike

It is possible that you need to run modprobe lirc and let me know if that helps

S

I am having the same issues.

Changed to the Confluence skin and no more problems.

Where is the OSMC section for settings etc under Confluence ?