OSMC reverted to default settings

Hello Community!

I have a strange situation with my installation of OSMC on Raspberry Pi3. On Monday I have updated my OSMC to Kodi17. After the update I read that Adjust Refresh Rate is enabled by default. I had some problems before with that (on Kodi16) and so I have decided to do fresh install of OSMC. After that everything started to work as intended and Adjust Refresh Rate worked great. I did some changes after installing (like skin, language, menu buttons, MySQL database, etc.) and it worked like it should. Yesterday my wife wanted to watch something and started Pi (I shutdown it overnight) and yell at me that something is wrong. When I saw the screen everything was back to default that were right after installation. Language was English (I use Polish), skin was OSMC (I use Transparency), resolution was 1080p@60 (I have set up 1080p@24 for test purposes of Adjust Refresh Rate), locales were all wrong. I did few restarts but nothing changed.

Unfortunately I forgot to grab logs.

Now, after some lengthy intro, my setup is: Pi3 connected via HDMI to Onkyo TX-SR578 AV Receiver, than via HDMI to LG C6 TV. OSMC is installed on my Synology NAS (like for ever, no changes were made to NFS shares), also I use Logitech Harmony remote. When I did fresh install I forgot to clean NFS location (this is my primary suspect) and tonight I plan on another fresh install but with wiping everything from NFS share. Next suspect is EDID data (because after reverting to defaults Adjust Refresh Rate option produced only black screen [like I had on previous OSMC installation]).

Now some questions:

  1. What could cause that strange behaviour?
  2. Which EDID file I should use for my OSMC? From AV Receiver or TV? Should I put the EDID file on microSD card? Or rather in home directory?

Hope someone will take some time to read it an find a minute to try and help me.

Broken SD card that went into Readonly mode. Try:

echo “test” > test.txt

and after reboot

cat test.txt

If result is “file not found” then SD Card gone

But there’s only boot files on SD. Nothing else. I’ll try that when I get back home.

You mean you have a USB installation?

Like I have pointed out in my first post, I have NFS installation. Everything is on Synology NAS.

Sorry, read it as media on NFS.
Then forget what I wrote.