OSMC + RPi + AdaFruit TFT not working

Hi All,

I have OSMC working on my rpi. I haven’t attached it to any video device (but it does work if I attach it through hdmi). I normally control OSMC through my phone (Kodi remote) and use it to play music.

I want to attach a small touchscreen and have OSMC work with that (so that I can control OSMC in absence of wifi, since the phone connects to OSMC through wifi). This doesn’t seem to work and OSMC continues to send video output through HDMI.

I followed these instructions to install adafruit pitft drivers. Unfortunately, I don’t even see /dev/fb1 after following the instructions. I know my hardware is good cause I’ve tried it with a standard raspbian setup, and the TFT works fine.

I’d really love if someone can help me out here. Pointers to existing information / list of stuff I could try or in general how I can debug this would be great! Please let me know if I can give more details to clarify the question.

Thanks in advance!


Did you ever find a solution to this?


I know this is an old topic but apparently no one ever got this solved anywhere. Althought it seems to be a wide spread request all over internet forums.

My ideal situation would be an OSMC player with small display. Not to play any video but for all other sources that don’t require video speed.

I tried about every suggestion I found but always without success. In the end it’s always the question how to get OSMC forced that it puts the data to the PITFT and not to the HDMI port.

I understand that the developers will have other priorities than this one but I wonder if it would be even possible to get the PITFT working?
And if not or if there are no plans to get it developed, could you at least inform us why?

I’m willing to help figuring out how to get the screen working but I’m still in a steep learning traject. So please forgive me asking stupid questions.

If you don’t intend to use Kodi for viewing of video, why do you wish to use OSMC? As an example, if you just intend the device as a music player, there are much better options under a Raspbian install such as mpd.

Because OSMC is far out the best app with a good development team?
And I need something that’s more or less “out of the box”.
I was searching for an alternative but I’d like to have a clean and simple GUI too and then OSMC looks for me the best solution.
I was looking at MPD but that’s only a deamon. So that’s not exactly what I was looking for.