OSMC sad face

#1

https://paste.osmc.tv/fuhukukoti

Hi , I have tried several times to update to the latest Kodi (I was using an old Kodi 16 for a long time). I tried using the OSMC installer, and I just tried to upgrade using apt-get dist-upgrade. Both ended up with the same result. The system seems to work for everything except Kodi. Just get a sad face, and it quits.
I see there is an error : May 08 22:59:35 vero mediacenter[1142]: /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/kodi.bin: undefined symbol: fbGetDisplayByIndex
May 08 22:59:35 vero sudo[2709]: pam_unix(sudo:session): session closed for user osmc .
Not sure what is this symbol lookup error.
Can anyone help ? I can always go back to kodi 16 again, but wondering if there is an obvious solution to this.

0 Likes

#2

Post the results of what happens when you try:

$ sudo apt update
$ sudo apt dist-upgrade

Also, you may try this to reset kodi settings:

$ mv .kodi kodi-save
$ sudo systemctl start mediacenter
0 Likes

#3

I got the same kodi error (symbol lookup error) when I tried your last suggestion.

sudo apt update:
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:3 http://ftp.debian.org/debian stretch InRelease
Hit:4 http://ftp.debian.org/debian stretch-updates InRelease
Hit:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Hit:5 http://ftp.debian.org/debian stretch Release
Reading package lists… Done

sudo apt dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

0 Likes

#4

Did you try?

$ mv .kodi kodi-save
$ systemctl restart mediacenter

I asked you to try that for a reason…

0 Likes

#5

i tried it, but got the same error

i just did a reboot, and now I can’t even ssh into the vero any more .
Instead of sad face, I now have blank screen.

I guess I have to wipe the SD card, and go back to kodi 16.

0 Likes

#6

Suggest you try a new SD Card

0 Likes