Osmc shutdown waiting

Hi all,
is it possible to edit the shutdown script responsible for delaying shutdown beacuse it’s terminating the movie that was played, or is it ‘umount’ script that waits.
The script echoes the message about terminating with defined time … first it is 1min30sec, after that if fails to terminate in that time waits for 3 mins. thx!

I should mention that the remote file system is mounted during boot with sshfs into /home/osmc/Movies/

Please show your /etc/fstab - you probably don’t have the right mount options to be compatible with systemd. (systemd requires different mount options in fstab than most other init systems)

/dev/mmcblk0p1 /boot vfat defaults,noatime 0 0
/dev/mmcblk0p2 / ext4 defaults,noatime 0 0
mrfsrf@ /home/osmc/Movies fuse.sshfs delay_connect,x-systemd.automount,_netdev,user,idmap=user,transform_symlinks,identityfile=/etc/ssh/ssh_host_rsa_key,allow_other,default_permissions,uid=0,gid=0 0 0

On previous, alpha version of osmc i could mount it as user ‘osmc uid 1000 / gid 1000’ after reinstalling new system, not alpha, every time i tred to mount as osmc, system would tried to mount as root or some other user.
Not that i think it matters with this issue.

Remove netdev and add noauto - see if that helps.

still no luck. Message about stop job running is still present

file system that is mounted is Mac OS Extended (Journaled) (HFS plus). Maybe because of that?

Hard to say - I have not tried sshfs on OSMC so without setting up a special test environment to test it I don’t have any answers off the top of my head. You may just need to experiment with the mount options.

BTW it’s very easy to set up an nfs server on Mac OS - it’s built in, and I use it on my Mac Mini. It is probably a much better option than sshfs because nfs was designed to be a network filesystem, whereas sshfs tacks a virtual file system onto the scp protocol.

Simply create an /etc/exports file then restart the service with ‘sudo nfsd restart’. The export options are a little bit different than Linux nfsd, here is my exports file as an example:

/Users/admin/Movies -mapall=admin:staff -network -mask
/Users/admin/nfs/RPi2 -maproot=root:wheel -network -mask

The first line is an example of a share for media content with all users mapped through to the user account that owns the files (in this case admin) and the second line is an example of a share designed for an NFS root install of OSMC.

ok thx for info. Sorry for my lack of knowledge,
how do you mount an nfs? can i still use fstab for that?

ona my mac
/Volumes/DUMPSTER2/Movies -mapall=osmc:osmc -network -mask
sudo nfsd restart

on osmc
/etc/fstab /home/osmc/Movies2 nfs nouser,atime,auto,rw,dev,exec,suid 0 0

after that sudo mount -a
i get

mount.nfs: mounting failed, reason given by server: No such file or directory