OSMC skin how to hide some Home page items?

Unfortunately this only worked for the older of my systems which is still running Kodi 18!
The system I allowed to upgrade from Kodi 18 to Kodi 19 a couple of days ago refuses to enable the main menu configuration!
It seems to start ok by downloading the needed add-ons, but then comes a series of alerts “blabla is not compatible with this version of Kodi”. There are a number of such notices, like 4-6 (did not count) until it exits without enabling configuration of the main menu.

One would have imagined that the upgrade from 18 to 19 would have handled this, especially since there was a nag message every time I switched to Kodi from the TV, but not… :japanese_goblin: :face_with_symbols_over_mouth: :rage:

So now I have a system with way too many main menu items, which I cannot configure…

Calm down now.

1 Like

It should only download one script. If it wants to download more, your upgrade to v19 and our recent update has somehow not been quite successfull. It would be good to see some logs here :slightly_smiling_face:

OK, I did this:

  • Enabled debug logging
  • Restarted OSMC from the Power menu
  • Then went into settings and tried to enable customizations, which failed because of “incompatible” add-ons
  • Disabled debug logging
  • Went to MyOSMC and uploaded the log

The URL is: https://paste.osmc.tv/fayubepahu

Hope you can find out the problem and remedy.

I have this same issue in v19. This was recently upgraded from v18 also, and the customization features were working in the previous version.

Unable to use “Enable Main Menu Customization” option, same errors about addons not being compatible.
“Skin Shortcuts” addon is installed but disabled. Cannot be enabled due to not being compatible error. “Skin Helper” Service was installed but I was able to remove from addons menu in attempt to fix, but when trying to reinstall it I get the same compatibility error.

Thanks for the reply, then I am not alone in this…
Seems like it should not be dismissed as “calm down” when a working system stops working properly after a suggested upgrade…

I wonder if there is a way to uninstall Kodi itself without touching the operating system and then install fresh from apt or similar?
The settings for media etc should be saved if possible.
All on an SSH command window preferably.

I doubt Kodi itself is your issues, I think the repositories are not updated. Looks like the update check never executes:

2021-08-22 11:10:45.107 T:601     DEBUG <general>: CRepositoryUpdater: closest next update check at 2021-08-22 11:55:52 (in 2707 s)

Have you tried to manually kick off a addon repository update?
Settings → Addon Browser → Kodi Repository → Context Menu → Update

1 Like

I went to the problem system and tried to find this, but failed…
On my system this is where I got:
Home → Settings → AddOn Browser →
But here there is no item “Kodi Repository”…
This is what I have on this page:

  • My AddOns
  • Available Updates
  • Install from repository
  • Install from zipfile
  • Search

So how do I get to the item you mention (Kodi repository)
And then:
How to I activate the “Context menu”, I only have a remote control on the TV via CEC transfer…

There you have your Kodi Repository.

Context Menu is normally launched via Menu Button or in that part you can click arrow left

Also that you have the menu item “Available Updates” shown indicates that your Addons are not up to date.

Could it be that you have disabled automatic updates of the Addons?

So I went there and inside that I used the left arrow button and there was only “check for updates”, which I used. The result was a report popping up saying that there are updates available.
But nowhere could I see where I can command an update of the Kodi repository itself, which is what I understood is what is needed.

Rather I have not enabled automatic updates in the first place, I generally do not like software to self-update behind the scenes suddenly rendering it unusable or changed in major ways without I knowing why…

But the major problem was that when I tried to enable the home menu configuration it told me that it needed to install new add-ons to do that, which presumably meant that there was missing add-ons for that function and that they were going to be installed. Which failed…
So that add-on cannot need update since it is not even installed, it needs a new install and that is what is failing by the looks of it.

Can some of these things be done from the command line instead with commands like sudo apt install xxx or similar?
It feels like one could get much more control that way…


So, has the update for the skinshortcuts script been installed correctly and is the home menu customization working again? I’m not sure I can quite figure that out from your previous post.

The problem is, to be frank, exactly this. The Kodi migration process from v18 to v19 is dependant on addons pulling updates from the Kodi repo that are needed to let them stay functional under v19. This is not loosing control that you’re forced to do, but inherent logic of an update… Addons need to update in the process as well and if you disable this happening automatically, you need to trigger the process manually… :wink:

This is indeed unfortuntate and misleading. Our skin shows this information because the broken (v18) script seems to be flagged as not usable and thus basically not installed by Kodi. The info is passed on to the skin and we simply show what Kodi delivers. It should say the addon is disabled at least, I have to admit. Not much we can do about that though, but you might report this over at the Kodi forum: broken/non-functional addons shouldn’t trigger feedback to the skin indicating that the addon is not installed at all.

No, it is not working since I found no way to update the repository (I assume this means something like sudo apt update, which gets the lists of applications updated).
But I will walk over now and enable app updates and see what happens then.

Well, should be pretty self explanatory… You click on this:

…and press “Install all” or only on the skinshortcuts script entry.

To be honest, when selecting that one doesn’t want updates to install automatically, it’s not really too much to ask to know or at least figure out (by using Google or browsing the Kodi wiki directly) how to install them manually, if needed: https://kodi.wiki/view/Add-on_manager#Updating
And personally, I’d say, that checking for addon updates should be a no-brainer after having performed an upgrade to the system while having set addon updates to manual and running into an issue with such an addon. But that’s just my two cents…

From command line, you can now(from kodi v.19) install from zip. But from the top of head, I don’t know where to get ahold of kodi_repository.zip.

Don’t really know how it works, just read it was implemented from console send command in 19

I went over to the problem Kodi19 system again and tried to run updates for all with pending updates.
Some succeeded but NOT the one it seems like it is needed, namely “Skin Shortcuts” now it claims that:
“dependency on python 2.x.x not satisfied” (I was not quick enough to note down the numbers)
So it seems like it cannot find python with the correct version…
But from my command window (PuTTY) into the RPi system:

ll /usr/bin/python*
lrwxrwxrwx 1 root root       7 2019-03-04 16:48 /usr/bin/python -> python2
lrwxrwxrwx 1 root root       9 2019-03-04 16:48 /usr/bin/python2 -> python2.7
-rwxr-xr-x 1 root root 2576604 2019-10-11 00:02 /usr/bin/python2.7
lrwxrwxrwx 1 root root       9 2019-03-26 11:25 /usr/bin/python3 -> python3.7
-rwxr-xr-x 2 root root 3288088 2021-04-05 11:00 /usr/bin/python3.5
-rwxr-xr-x 2 root root 3288088 2021-04-05 11:00 /usr/bin/python3.5m
-rwxr-xr-x 2 root root 3538304 2021-01-22 21:04 /usr/bin/python3.7
-rwxr-xr-x 2 root root 3538304 2021-01-22 21:04 /usr/bin/python3.7m
lrwxrwxrwx 1 root root      10 2019-03-26 11:25 /usr/bin/python3m -> python3.7m

So I would say that both python2 and python3 are available on this system, actually with several different versions too.
So what is really the problem here?

I found this from 2017:

Is this a valid way to start over without reinstalling Kodi19 but without the add-ons that are having problems?
So the Kodi settings may be kept meanwhile?

Thanks for this reply. I presumed Addon version mismatches were the issue here, but its been a while since ive used repositories, so forgot you could run those updates.
Happy to report this function is now working fine for me after updating all addons.

1 Like

I went ahead and did this, essentially hosing all of my previous settings and starting over.
Now it was possible to enable home menu configuration which installed the Skin Shortcuts add-on successfully.
But in the process all of my configurations done over a number of years are gone and I have to either back-track or start over configuring the media center…

Anyway the problem with the add-on is now located in the .kodi_backup directory and not in the newly created active .kodi dir…