Osmc stops streaming, cant access/control osmc anymore

Hello there.
I’m using osmc just for streaming radio with my RasPi3. The system is running for more than 6 hours and all off a sudden the stream stops → no audio anymore. This happens everyday.
Locking at the frontend the osmc logo appears put freezes and in the upper right it says “zwischenspeichern…” (buffering?) I can’t control osmc via my keyboard and have to unpower the RasPi to restart. Even via yatse I can’t restart or shutdown the system.

There are two pastes I threw into pastebin.
This one is from systemstart this morning 'til it crashed
kodi.old 2021-11-15 16-10-55.log https://pastebin.com/T3khnpht
This one is after Ipowered off the system and restart
kodi 2021-11-15 16-28-42.log https://pastebin.com/ti2rgFSi

Any idea what is happening here?
Thanks for your support! Cheers Jens

You should post full logs via My OSMC.

OK. It happened again: Audio is off all of a sudden. but I can access the osmc frontend.
The logfile is pasted here https://paste.osmc.tv/xivonenase.xml
For some reason paste.osmc.tv didn’t return a code after uploading via my My OSMC
So I pasted manually. see above link.
Any idea what is going on with the system?
Thanks Jens

These are just Kodi logs.

It’s likely the full log size was too big.

2021-11-18 07:56:43.430 T:448     DEBUG <general>: CFileCache::Process - <http://metafiles.gl-systemhaus.de/hr/hr1_2.m3u> source read didn't return any data! Hit eof(?)

The connection dropped out.

Now after writing the previous post I tried to start again a radio stream.
(around 2021-11-18 14:38:15) and the whole frontend did stop meaning no keyboard access anymore. ??? I had unpower the raspi.
The new paste is here: https://paste.osmc.tv/ixanociduj.xml
Line 56733 and following of the previous paste
For some reason I couldn’ t paste all of the log file. The website replied “something went wrong” after hitting the save button. (maybe bacause of 65536 = 2¹⁶ lines???)
Cheers Jens

What other logfiles you mean?
The last logfile size was about 10MB, the one before just 355kB

So I did a reboot via my laptop But now I’ll have to wait another 6 hours for this to happen again :slight_smile:

OK finally I found the time to check and upload the logfiles.
we moslty listen to this radio stream
and all of a sudden the stream stops and most times doesn’t start again by itself.
Sometimes the display is showing “Zwischenspeichern…” but nothing happens.
Sometimes I have to restart the raspi.
Any idea what is causing the issue?

Are you playing it just as a stream via a strm file?
I suggest you try using the Radio Addon

I tried the Radion Addon as well and was having the same issues.

Then would suggest to check your network connection, are you using WiFi or power line?

Maybe something changed in the network, we suggest to check your network with iperf3. Please read this howto

the Raspi is diectly connected with a LAN cable to a switch and the switch via LAN to the Fritzbox router

I still having problems.
What is osmc/kodi doing when on the screen a small window pops up saying:
“Zwischenspeichern…” What is it saving?
No proress bar respectivle not continuing.
How can I stop this “Zwischespeichern…” or cancel it?
I can operate any other menu (like watching pictures) but can’t play streams anymore.
Your help is very much appreciated. Thanks.

Provide new logs demonstrating the issue if you would like meaningful assistance.

Thanks for your reply!
I started the system a couple of times so the most recent log might not have the information in regards to the stopping of the stream.
I will again post the logs tomorrow when it happens again.

My actual question was:
What is osmc/kodi doing when on the screen a small window pops up saying:
“Zwischenspeichern…” What is it saving?
No proress bar respectivle not continuing.
How can I stop this “Zwischespeichern…” or cancel it?

Guys that is the translation from the English buffering which would indicate OSMC is trying to cache data to have enough to playback the stream.
So as indicated earlier I still assume a network issue while it might also could be an audio pipe issue as someone reported this on librelec

I just noticed in all cases the stream stops after 5:59:59
Could it be that the stream provider cancels the stream after 6hours?
But for some reason while kodi is trying to buffer something (the canceled stream?) it doesn’t react to any control. In most cases I have to reboot the system.
That’s driving me (actualy my wife) crazy!
What can I do?


I’d suggest asking the provider.