OSMC stuck on "Preparing"

Recently, my Vero 4K+ get’s stuck almost every time I try to play a. file from my network connected PC.
Other Kodi devices that are connected to the same PC play the same files as usual.
After it gets stuck/hand, I have to disconnect the power cord and reconnect.
Even then, I get a “preparing” message instead of scanning.
This is a sign that if I’ll try to play a file, it will get stuck again.
I need a few cycles of stuck and restart, until I manage to get it to work.

Link to log:

I enabled logging, tried to play a file and got stuck. Did a restart and uploaded the log.
I hope it captured the error.


What exactly were you trying to play? Between the library update, PVR, and quite a bit of dialog from add-ons I’m having trouble spotting it in those logs.

I was just trying to play a file from my library, saved on my PC that is on the same subnet.
I worked a thousand of times, but now it seems it has some trouble connecting to the PC.
Other computers at home use Kodi, connect to the same PC, and do not show any issue.

I will try to recreate this error with another log.

Taking another look in your log I see that your ethernet connection came up and got an IP address but then it shows that it disconnected about a half hour later. Maybe you should look into your cables, connections, or try a different port on your switch.

Will do.
Thank you.