OSMC unable to boot

Am having a rather frustrating time with osmc at the moment. I switched over to osmc from raspbmc about 4 months ago and was very impressed with the system when I first installed it. About a month back it suddenly refused to boot. I can’t remember the error message, but we have a lot of load shedding so assumed that a power failure had damaged the system. Since then we have installed a UPS so yesterday I finally got round to reinstalling. I booted up and in the osmc interface added in my Movies which worked fine and then left it to work through my Music files. I knew this would take a while so left it to run. After about 6 hrs I checked back in and the system had frozen mid-music library check. While we are no longer affected by power cuts, our ISP is and the time on the frozen system matched the time the power went out for our ISP. Nothing I did seemed to be able to unfreeze the system so I was forced to pulling the plug out.

Now when I boot it up I get this:

(1 of 3) A start job is running for Set Time using HTTP quer…n xxs / no limit
(2 of 3) A start job is running for Trigger Flushing of Jour xxs / no limit
(3 of 3) A start job is running for /etc/rc.local-Compatibility xxs / no limit

A whole load more checks run then a series of Failed messages e.g.

Failed to start Trigger Flushing of Journal
Failed to start LSB: NTP daemon
Failed to start ‘Permit User Sessions’

Power is still out for our ISP. Is it possible that a lack of internet is preventing the entire system from booting up? If so I am going to need to find another system to run as our DAILY power outages last 8-10hrs minimum and it is frustrating to have a UPS system that powers the Pi, but we can’t use it without internet.

If anyone understands the above messages and I have got the wrong end of the stick or there is something I can do about this then please let me know.

Thanks in advance

Are you able to access SSH?
Mount the card on a *nix box?

It would be awesome if you could and then grab the logs.

No – this will not cause an issue


Thanks for the responses. Glad internet isn’t the issue.
I can’t SSH into box, but can pull any logs by mounting the SD card on another linux box. Which logs should I pull?
Am also happy to do a fresh install as haven’t customised anything yet…

the logs are located in:-


Grab both kodi.log and kodi.old.log

paste the text into two separate pastes on:-

Hi CaNsA. There was only the kodi.log entry - no sign of a kodi.old.log file.

I copied the contents into the pastebin and pressed save. Was expecting to get a url to paste here for you to see the contents, but nothing appeared when I saved and couldn’t see a link. Am I doing something wrong?

The URL would have been in the address bar at the top of your browser.

That is what I thought, but the URL is just http://paste.osmc.io/

Im guessing it isn’t saving and therefore creating a new url. Will try in a different browser…

OK looks like it was just down to the size of the content. Here it is: http://paste.osmc.io/rexamakusu.vhdl

If you aren’t fussed to re-install, it would be a much better use of any further time rather than sort out why this install is seemingly so borked.

As I suggested in an earlier post, I’m totally happy to reinstall… Before I do though, is there anything to suggest that the SD card might be at fault?

Not that can be seen from your simple kodi.log.

Cool - thanks for all of your help. I will go for a reinstall and keep my fingers crossed…

OK so I reinstalled, got things set-up and then turned off the system. Now when I turn it on, I get the following message, but nothing happens:

/mmcblk0p2: clean, 28320/225792 files, 213887/901888 blocks

The left hand side of the screen doesn’t show so am guessing I am missing /dev at the start of the message.

Any ideas? This is the third install of osmc to fail in a fairly relatively quick time. Each time the error is different. I can’t believe the software is this buggy - is it possible some hardware is failing???

how are you turning off? Just by pulling the power or are you shutting down the system from within Kodi first?

I shutdown from within Kodi. With the current above error message it is unresponsive to anything so have to pull the plug.

Yes, the software is not this buggy, it is almost certainly a hardware issue.

Have you tried a different SD card yet ? A different power adaptor ?

You’re wasting your time trying to find a software solution to what will be a hardware problem. A clean install of OSMC does not just fail to boot for no reason after shutting down. :wink:

Apologies for taking so long to reply back on this. I managed to identify the issue was the SD card which I have now replaced and everything worked perfectly. Thanks for all the advice and support.

Unfortunately it now seems to time out (blank screen and no sound) about a third of the time when I select to play something with the Android ‘Kore’ app. Should I start a new thread for this new issue?

Yes and provide full debug logs