OSMC Update error bluez-obexd

The following error came up while updating.

Error installing: bluez-obexd(5.43-2+deb9u1)

I tried apt-het install it with the following error

After this operation, 377 kB of additional disk space will be used.
(Reading database ... 44729 files and directories currently installed.)
Preparing to unpack .../bluez-obexd_5.43-2+deb9u1_armhf.deb ...
Unpacking bluez-obexd (5.43-2+deb9u1) ...
dpkg: error processing archive /var/cache/apt/archives/bluez-obexd_5.43-2+deb9u1_armhf.deb (--unpack):
 trying to overwrite '/usr/share/dbus-1/services/org.bluez.obex.service', which is also in package armv7-bluez-osmc 5.43-3
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

You have two packages that claim to “own” a file, in this case /usr/share/dbus-1/services/org.bluez.obex.service.

This usually happens when you add an extra repository to /etc/apt/sources.list.

cat /etc/apt/sources.list

deb http://ftp.debian.org/debian stretch main contrib non-free

deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://apt.osmc.tv stretch main

I did say usually. :wink:

In this case the two packages are current but overlap on one file.

Is there a reason why to chose to install the bluez-obexd package, since it unfortunately conflicts with armv7-bluez-osmc?

Not one I remember of.
I tried to play around, in order to make the onboard bluetooth chipset to work. With no success…
As a result, the bluetooth is idle now, so I can remove any related blue* packages.
What should I remove?

Without knowing what you installed, that’s a tough question to answer!

If you can remember what you installed, try to reverse the process. If you can’t remember, take a look in /var/log/apt/history.log.

thank you @dillthedog.
Just a chaos in here…
I suspect blueman or pulseaudio

Start-Date: 2017-10-20 12:00:43
Commandline: /usr/bin/apt-get-real install blueman
Install: . . . libbluetooth3:armhf (5.23-2+deb8u1, automatic), . . . blueman:armhf (1.99~alpha1-1+deb8u1)


Install: libdatrie1:armhf (0.2.8-1, automatic), gir1.2-notify-0.7:armhf (0.7.6-2, automatic), gconf-service:armhf (3.2.6-3, automatic), libgdk-pixbuf2.0-0:armhf (2.31.1-2+deb8u6, automatic), libcroco3:armhf (0.6.8-3+b1, automatic), dconf-service:armhf (0.22.0-1, automatic), libdconf1:armhf (0.22.0-1, automatic), glib-networking-common:armhf (2.42.0-2, automatic), libxcb-render0:armhf (1.10-3+b1, automatic), libgtk-3-bin:armhf (3.14.5-1+deb8u1, automatic), libmagickcore-6.q16-2:armhf (, automatic), xkb-data:armhf (2.12-1, automatic), libxrender1:armhf (0.9.8-1+b1, automatic), libdbusmenu-gtk3-4:armhf (12.10.2-1, automatic), libatk1.0-data:armhf (2.14.0-1, automatic), libwayland-client0:armhf (1.6.0-2, automatic), libxcomposite1:armhf (0.4.4-1, automatic), libpixman-1-0:armhf (0.32.6-3, automatic), libjson-glib-1.0-common:armhf (1.0.2-1, automatic), libgtk-3-0:armhf (3.14.5-1+deb8u1, automatic), libproxy1:armhf (0.4.11-4+b2, automatic), fontconfig:armhf (2.11.0-6.3+deb8u1, automatic), libxcb-shm0:armhf (1.10-3+b1, automatic), python-gi-cairo:armhf (3.14.0-1, automatic), gir1.2-freedesktop:armhf (1.42.0-2.2, automatic), libxinerama1:armhf (1.1.3-1+b1, automatic), libmagickwand-6.q16-2:armhf (, automatic), libpangoft2-1.0-0:armhf (1.36.8-3, automatic), librsvg2-2:armhf (2.40.5-1+deb8u2, automatic), obex-data-server:armhf (0.4.5-1+b2, automatic), libdbusmenu-glib4:armhf (12.10.2-1, automatic), libvorbisfile3:armhf (1.3.4-2, automatic), libfftw3-double3:armhf (3.3.4-2, automatic), libxkbcommon0:armhf (0.4.3-2, automatic), libappindicator3-1:armhf (0.4.92-3.1, automatic), libbluetooth3:armhf (5.23-2+deb8u1, automatic), libcolord2:armhf (1.2.1-1+b2, automatic), libjson-glib-1.0-0:armhf (1.0.2-1, automatic), notification-daemon:armhf (0.7.6-2, automatic), libcairo-gobject2:armhf (1.14.0-2.1+deb8u2, automatic), libxrandr2:armhf (1.4.2-1+b1, automatic), libsoup2.4-1:armhf (2.48.0-1+deb8u1, automatic), librest-0.7-0:armhf (0.7.92-3, automatic), hicolor-icon-theme:armhf (0.13-1, automatic), gir1.2-gtk-3.0:armhf (3.14.5-1+deb8u1, automatic), libcanberra-gtk3-0:armhf (0.30-2.1, automatic), libstartup-notification0:armhf (0.12-4, automatic), libsoup-gnome2.4-1:armhf (2.48.0-1+deb8u1, automatic), glib-networking-services:armhf (2.42.0-2, automatic), gsettings-desktop-schemas:armhf (3.14.1-1, automatic), gir1.2-appindicator3-0.1:armhf (0.4.92-3.1, automatic), gir1.2-atk-1.0:armhf (2.14.0-1, automatic), liblqr-1-0:armhf (0.4.2-2, automatic), gir1.2-gdkpixbuf-2.0:armhf (2.31.1-2+deb8u6, automatic), libpango-1.0-0:armhf (1.36.8-3, automatic), libopenobex1:armhf (1.5-2.1, automatic), libxfixes3:armhf (5.0.1-2+b2, automatic), gir1.2-pango-1.0:armhf (1.36.8-3, automatic), libatk-bridge2.0-0:armhf (2.14.0-2, automatic), gnome-icon-theme:armhf (3.12.0-1, automatic), adwaita-icon-theme:armhf (3.14.0-2, automatic), libxft2:armhf (2.3.2-1, automatic), libcanberra0:armhf (0.30-2.1, automatic), libxcb-util0:armhf (0.3.8-3, automatic), libthai-data:armhf (0.1.21-1, automatic), imagemagick-common:armhf (, automatic), libatspi2.0-0:armhf (2.14.0-1, automatic), libgdk-pixbuf2.0-common:armhf (2.31.1-2+deb8u6, automatic), shared-mime-info:armhf (1.3-1, automatic), libpangocairo-1.0-0:armhf (1.36.8-3, automatic), blueman:armhf (1.99~alpha1-1+deb8u1), libxdamage1:armhf (1.1.4-2+b1, automatic), python-cairo:armhf (1.8.8-1, automatic), libxcursor1:armhf (1.1.14-1+b1, automatic), python-support:armhf (1.0.15, automatic), libatk1.0-0:armhf (2.14.0-1, automatic), libgconf-2-4:armhf (3.2.6-3, automatic), libindicator3-7:armhf (0.5.0-2, automatic), dconf-gsettings-backend:armhf (0.22.0-1, automatic), libpulse-mainloop-glib0:armhf (5.0-13, automatic), gir1.2-gconf-2.0:armhf (3.2.6-3, automatic), libpangoxft-1.0-0:armhf (1.36.8-3, automatic), glib-networking:armhf (2.42.0-2, automatic), gconf2-common:armhf (3.2.6-3, automatic), librsvg2-common:armhf (2.40.5-1+deb8u2, automatic), libcairo2:armhf (1.14.0-2.1+deb8u2, automatic), libthai0:armhf (0.1.21-1, automatic), libgtk-3-common:armhf (3.14.5-1+deb8u1, automatic), libwayland-cursor0:armhf (1.6.0-2, automatic), libnotify4:armhf (0.7.6-2, automatic)

Start-Date: 2017-10-20 14:01:32
Commandline: /usr/bin/apt-get-real install pulseaudio pavucontrol pulseaudio-module-bluetooth


Install: pavucontrol:armhf (2.0-3), libatkmm-1.6-1:armhf (2.22.7-2.1, automatic), libglibmm-2.4-1c2a:armhf (2.42.0-1, automatic), libgtkmm-3.0-1:armhf (3.14.0-1, automatic), libcairomm-1.0-1:armhf (1.10.0-1.1, automatic), libpangomm-1.4-1:armhf (2.34.0-1.1, automatic), libsigc+±2.0-0c2a:armhf (2.4.0-1, automatic)

Start-Date: 2018-02-05 23:01:00
Commandline: /usr/bin/apt-get-real -o APT::Status-Fd=4 -o APT::Keep-Fds::=5 -o APT::Keep-Fds::=6 -f -y dist-upgrade
Install: . . . . bluez-obexd:armhf (5.43-2+deb9u1, automatic), . . .
Error: Sub-process /usr/bin/dpkg returned an error code (1)

Yep, blueman looks like a good candidate:

osmc@osmc:/var/log/apt$ apt-cache rdepends bluez-obexd
Reverse Depends:

sudo apt-get remove blueman

but still
trying to overwrite '/usr/share/dbus-1/services/org.bluez.obex.service', which is also in package armv7-bluez-osmc 5.43-3


Try sudo apt-get remove blueman

@sperfect copy paste error, should have been sudo apt-get purge blueman

Thanks Tom.

Here’s a lateral approach. Remove armv7-bluez-osmc first.

Update. Not a good idea, since it can have some unfortunate side-effects. :frowning:

Seems it will remove a lot…

 sudo apt-get remove armv7-bluez-osmc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  armv7-connman-osmc cifs-utils curl iproute2 iptables libelf1 libical2
  libip6tc0 libiptc0 libmnl0 libnetfilter-conntrack3 libnfnetlink0 libnl-3-200
  libnl-genl-3-200 libnss-myhostname libpcsclite1 libpkcs11-helper1
  libxtables12 net-tools openvpn python-dbus python-gobject samba-common wget
  wireless-firmware-osmc wpasupplicant
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  armv7-bluez-osmc armv7-network-osmc rbp2-device-osmc
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 5192 kB disk space will be freed.

I hope you replied No!

@Tom_Doyle tried purge, with the same result

Did you ever try sudo apt-get purge bluez-obexd?

Package ‘bluez-obexd’ is not installed, so not removed


I tried to install blueman on my machine and saw the same error as you. But I then had no problems running sudo apt-get purge blueman to remove it.

Therefore please run grab-logs -a -o -O and provide the URL.

Here you are

From your logs it seems that the bluez-obexd package was introduced as a dependency of blueman in Debian stretch. Now that blueman has been removed, it’s not clear what the problem is. I suggest you try a few things:

sudo apt-get purge bluez
sudo find /var/lib/apt/lists -type f -delete
sudo apt-get update
sudo apt-get dist-upgrade

and see if the error remains.