OSMC Update Error in package libc6 (2.28-110.2)

Dear OSMC-Team,

prompted to report this problem on OSMC forum.
Hope this logs will help: https://paste.osmc.tv/imuribahav

Thanx and kind regards


We are aware of that and looking into it.

This is already fixed - just check for updates again.

Sorry, tried updates again for several times:
first “Processing triggers for libc-bin (2.28.-110.1)”
and than “An error occurred while installing the following package: libc6 (2.28-110.2)” again…

Are you updating via My OSMC or the command line?

Can you post some logs?

The correct version ends in -3


To clarify: some fresh logs.

You might need to go to My OSMC - Updates - Manual Controls and select Check for Updates now.

Otherwise your device will download the fixed update over night.


I’m getting the same error even after checking manually for updates

Log in into your Vero using putty or ssh - and try the following:

systemctl stop mediacenter
sudo apt update
sudo apt -y dist-upgrade
systemctl start mediacenter

If there is a new kernel, I tend to reboot the device though.
But in general, this is what I tend to do.

There were some issues propagating to the mirrors, but this has now been fixed.

I’d suggest checking for updates again in an hour and things should go through fine.

Now it worked with My OSMC - Updates - Manual Controls and select Check for Updates now.
Thanx for your great support!

Thanks for confirming that this is resolved.
Apologies for the initial issue.

Fixed for me too! Thanks!