OSMC Update Error message

#1

Hi not sure if there is an issue with my Vero 4K? I’m not getting auto updates so have tried scanning but keep getting following message:

OMSC Update Error
Error installing:
Please report this on the OSMC forum

I’m guessing I’ll need to upload something but am unsure of what to do/how to do it. Screen tells me OSMC July 2019 2019.07-1

Any help greatly appreciated thanks

#2

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

#3

Thanks for link - I can’t upload any logs and so not have any Ethernet connection any ideas??

#4

Just realised I have no ethernet wires connection IP ADDRESS 169.254.58.243

Tried rebooting Vero 4K and router still no luck. Don’t know how to upload log (and would have to do this wireless in any case

#5

Hi,

Your probably seeing the error, because there is no internet connection. MyOsmc check for updates periodically, if offline will produce an error as you’ve posted above.

If you are using your vero4k offline, then just disabled automatic checks for updates via MyOSMC; and just connect to the internet when an update has been released and manually update.

If your vero4k is meant to be online and you are having issues, please provide us more details of your setup.

Thanks Tom.

#6

Morning Tom thanks for the replies - I do normally use my Vero online via a wired Ethernet connection.

For some reason it will not connect to wired connection anymore?

I can connect via wireless but I need faster connection using wired to play 4K content.

I have read helpful post re reporting problems but can’t figure out how to upload logs. Any ideas??!

#7

I gave you the exact link.

#9

You could upload the logs while connected via WiFi. Means boot with cable connected then after a while connect WiFi and upload.

But did you check your network? Router, cable, settings…

#11

The user is getting a private IP which suggests something is up with DHCP

I suggest rebooting the router first before doing anything further

#12

Thanks Sam I rebooted router still no joy.

Yes I followed exact link re uploading logs but still can’t figure it out sorry.

#13

What are you struggling with?

#14

How to upload logs

#15

You can upload logs via MyOSMC

#16

This might be better:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

2 Likes
#17

Brilliant thanks Sam - sorry for being such a dunce! I’ll get into this when I get in from work thanks again all

#18

I cannot get DHCP Wired connection to internet. I have checked and rebooted router, cables etc and tried with other items in home which all work fine.

I have tried to replicate issue, then used wireless to upload log:

https://paste.osmc.tv/casavirapi

If not can you provide instructions on how to invoke command lines eg
ssh method invoking command grab-logs -A

#19

Try set a static IP first and see what happens
Do you run a custom DHCP setup? What’s the make and model of router?

Do you see an activity light on the switch / router?

#20

Have you tried plugging a different device into the same cable that the Vero is plugged in with? In the logs it does not look like the Vero is receiving anything on ethernet.

#21

I have tried to enter static IP address. Dont know what to enter fir subnet mask, default gateway, Primary DNS, Secondary DNS. When I hit apply I get message 'Networking Add-on Unhandled exception caught-see log for details.

My router is Sky ER110, all other devices are using wireless internet without issue and all lights are on router

#22

Ive just reset powerline adaptor, rebooted router and vero and its all now working again??!!! Think powerline must have thrown wobbler.

Thank you so much for help - very grateful.

Just one other query - when setting primary and secondary DNS I’ve noticed some people choose primary to be 8.8.8.8 and secondary as their own router - is there any merit in doing this eg faster speeds?? Is this something I should consider doing?