OSMC Update Error


I posted on another thread about this issue but unfortunately this issue is still on going. For the past month or so whenever my pi3 tries to update I get this message:

After 30 seconds my pi does reset and I get this message:

Here is the log: http://paste.osmc.io/ajoyuqumuk

Any help would be much appreciated. Thanks

Do a dist upgrade manually and post if you have any issues

Thanks for the reply, tried that but unfortunately still showing an error:

osmc@WillsPi:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following packages were automatically installed and a re no longer required:
libasn1-8-heimdal libgssapi3-heimdal libhcrypto4-heimdal
libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal
libkrb5-26-heimdal libroken18-heimdal libwind0-heimdal
rbp2-image-4.4.13-1-osmc rbp2-image-4.4.13-5-osmc
Use ‘apt-get autoremove’ to remove them.
The following NEW packages will be installed:
The following packages will be upgraded:
armv7-connman-osmc armv7-network-osmc base-files-osmc curl fontconfig-config
libcurl3 libfontconfig1 libmysqlclient18 mysql-common ntp openssh-client
openssh-server openssh-sftp-server perl-base rbp-bootloader-osmc
rbp-userland-osmc rbp2-kernel-osmc rbp2-libcec-osmc rbp2-mediacenter-osmc
20 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/58.8 MB of archives.
After this operation, 66.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages …
dpkg: unrecoverable fatal error, aborting:
unable to open files list file for package `libdb5.3:armhf’: Structure needs cl eaning
E: Sub-process /usr/bin/dpkg returned an error code (2)

Try sudo apt-get clean. Looks like you may have experienced some filesystem corruption. You may need to reinstall.

Same result. Guess its a reinstall in that case. Just when I got everything as i wanted it!

Try and backup your .kodi install first! Worth a shot to try and import it into your new install anyway.

Was actually just reading how to do that. Although am wondering (possible stupid question alert) would it not also copy over the corrupted files too and therefore just cause the problem to keep happening?

There is nothing there to indicate that the Kodi files are broken, the issue you seem to be having is elsewhere in the system that’s why a reinstall is probably the best bet. With a bit of luck your Kodi files are all fine and that’ll be an easy way for you to transition.

same thing happen to me i be dealing with this error