OSMC Update nothing happens [CLOSED]

Hi, since the last two updates, my RPI 2 does not want to update through My OSMC.

When I click on the “Check for updates now” dialog, literally nothing happens. There is no notification of any kind. On my other instance running on RPI 3 it works as intended. Is this a known issue?

I can update my RPI 2 through SSH, but that is inconvenient.


Surely not (as you could also see from the forum).
Please enable debug logging, try to upgrade via MyOSMC and then upload complete logs.

Sorry, should have done so from the start. Here you go: https://paste.osmc.tv/zujuweqeca



Start-Date: 2018-08-14  18:40:16
Commandline: /usr/bin/apt-get-real dist-upgrade
Requested-By: osmc (1000)
Upgrade: linux-libc-dev:armhf (4.9.110-1, 4.9.110-3+deb9u1), libwbclient0:armhf (2:4.5.12+dfsg-2+deb9u2, 2:4.5.12+dfsg-2+deb9u3), samba-libs:armhf (2:4.5.12+dfsg-2+deb9u2, 2:4.5.12+dfsg-2+deb9u3), samba-common:armhf (2:4.5.12+dfsg-2+deb9u2, 2:4.5.12+dfsg-2+deb9u3), libsmbclient:armhf (2:4.5.12+dfsg-2+deb9u2, 2:4.5.12+dfsg-2+deb9u3)
End-Date: 2018-08-14  18:41:15

Start-Date: 2018-08-14  18:42:58
Commandline: /usr/bin/apt-real autoremove
Requested-By: osmc (1000)
Remove: rbp2-image-4.14.34-1-osmc:armhf (1)
End-Date: 2018-08-14  18:43:03

Looks like osmc successfully updated yesterday.

Thanks Tom.

Yes, but that was done manually through SSH.

Well nothing unsual to be seen in the logs. But most likely at that time no updates where available as you had manually updated on the 14th already.
Maybe wait for the next month OSMC update.

This doesn’t look right:

Aug 15 18:19:59 osmc-2 mediacenter[508]:   File "/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/apt_cache_action.py", line 19
Aug 15 18:19:59 osmc-2 mediacenter[508]:     print '%s %s sending response' % (t.now(), 'apt_cache_action.py')
Aug 15 18:19:59 osmc-2 mediacenter[508]:                                  ^
Aug 15 18:19:59 osmc-2 mediacenter[508]: SyntaxError: invalid syntax

The problem might lie elsewhere but the first step should be to reinstall the package that contains the failing python script:

sudo apt-get install --reinstall mediacenter-addon-osmc

Tried to reinstall the addon, without success. Here is the new log, after reinstall.


The same error still persists.

I’d guess that something else has become corrupted. You can try to reinstall the python library again:

sudo apt-get install --reinstall libpython2.7-minimal

but if that doesn’t work, it’s probably going to be safest and easiest to go for a reinstall.

You should also consider using a new SD card.

Ok, will do, and update the situation.

Thanks for the support!

Reinstalling python lib did not fix the problem :sob:

Resolved by reinstalling OSMC.