OSMC Updates fail

I have the following issue: every OSMC related install fails, whether it is an update or when I’m trying to install e.g. Samba from the ‘shop’

No idea what’s going on here. What logs are relevant, so I can upload them?

(my Pi3 is connected to the internet)

UPDATE: running sudo apt-get dist-upgrade DID update my OSMC to the October 2017 version, whereas update via My OSMC fails everytime

Regards
Joost

grab-logs -A

Do I really need to dump all the log files?

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

No one else is reporting this problem. If you want it resolved we do need to see logs.

If you’re familiar with the command line then you may have made other modifications to your system which have caused this problem.

I hope you can understand. It’s like saying your car won’t start but refusing to lift your bonnet.

I don’t mind delivering the log files. I’m just wondering if all the files are necessary. In your words, do I need to pop the trunk for an engine problem?

Regards
Joost

If we give you the same answer a third time will it be sufficient?

1 Like

The issue you are currently experiencing with OSMC

Updates for OSMC are failing to install

What you were doing when this issue occurred

Opened My OSMC > Updates > Manual > Scan for updates now

Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.

See steps above

The device you are currently running OSMC on

Raspberry PI 3

What peripherals are attached to the device?

External HDD, Wifi USB dongle, Keyboard USB Unifying receiver

Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?

Nope, this issue has always been around

http://paste.osmc.tv/ededafotoj

Before uploading any logs, you should ensure that Debugging is enabled in Kodi. This can be done by going to Settings -> System -> Logging -> and selecting Enable Debugging. You should then perform a reboot of your device and perform only the minimum actions required to replicate this issue so that it is easy to identify the cause of the problem.

Ok, here you go
http://paste.osmc.tv/apiguxixez

Failed to fetch http://packages.unusedbytes.ca/dists/wheezy/main/binary-armhf/Packages

You need to remove all the cruft from your APT source file(s).

OSMC is currently on Debian jessie and soon to move to stretch.

How do I do that? This is new to me

====================== APT sources.list =================== ZZz2wrJ1
deb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

deb http://packages.unusedbytes.ca wheezy main

---------------------- APT sources.list END --------------- 

It appears your /etc/apt/sources.list contains extraneous sources that are causing a problem… Remove or comment out the offending repo. We can only assume you added it as OSMC did not.

The same way you added it.

3 Likes

SOLVED
I removed an entry from

/etc/apt/sources.list

and now I get no error message when updating

Thanks guys!