OSMC Vero 4K+ Dolby TrueHD


I own a Vero 4k+ which is connected to a Yamaha AV Receiver. In the settings of the Vero 4K+ is “Passthrough” for Dolby True HD activated. When I switch to a Dolby True HD track, I don’t get any sound. The display of the receiver switches to PCM. AC3 is fine though.

Any ideas on how to fix this? I really don’t want to buy a new receiver. It is a Yamaha RX V-2067.


Post logs please so we can check your settings.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I did a receiver reset and a clean install of the Vero 4k+ from an USB stick.
I used a downloaded sample for a TrueHD file. It’s also the same with my own saved BRs.

Are you sure the Vero 4k+ is connected to the Yamaha AVR but not to the Panasonic TV instead?

====================== EDID =================== wE0go885
Rx Manufacturer Name: MEI  <---- ???????????
Rx Product Code: a064
Rx Serial Number: 0000000e
Rx Product Name: PANASONIC-TV

From the “Panasonic” Wikipedia article: “From 1935 to October 1, 2008, the company’s corporate name was “Matsushita Electric Industrial Co.” (MEI).”

So, I would expect to find a Yamaha representing string in this field. But, perhaps this is just cosmetic. @grahamh owns a Yamaha, afaIk.

No. The Vero is connected directly to the AV Receiver. I also changed the AV (IN)port for the Vero. That changed nothing. The TV (an old Panasonic) is connected via the HDMI-(Out)port on the back of the receiver.

Ok, can you frist try whether you can set the output device at settings -> system -> audio -> output device to 'AML-MESONAUDIO, HDMI` ?

Although most possible not related to your issue: Why you have set Adjust Display Refresh Rate set to off instead of start/stop? (settings->system->player->video)
Also, you’re using a small GUI resolution; recommendation is to use 1920x1080 at system->settings->display.

User has an old TV that’s probably native 1360x768, so 1280x720 is as good as any.

@shire All I can suggest is to try a different HDMI input (you have plenty to choose from!) and/or a different HDMI cable.

It’s an old 720p TV. Switching the output device changed nothing.:-/

Another cable and another port changed nothing. I also noted the following:

When I try to playback the TrueHD files I get no audio. When I change to DTS (even MA) /AC3 I get also nothing. I have to turn of the receiver to get the AC3/dts track again.

I think it’s time to get a new receiver (perfect time to buy one :frowning_face:). That think is almost 10 years old.

Did you check the AVR firmware version ?


I was also a little curious about these settings - in particular

Number of channels: 5.1 ===> Default: 2.0

Try setting it to 7.1.

====================== GUI Settings (abridged) =================== z9Z12KgS
Dolby Digital (AC3) capable receiver: true
Enable Dolby Digital (AC3) transcoding: false
Audio output device: ALSA:default
Number of channels: 5.1 ===> Default: 2.0
Output configuration: Best match
DTS-HD capable receiver: true
DTS capable receiver: true
Dolby Digital Plus (E-AC3) capable receiver: true
Play GUI sounds: Only when playback stopped
Allow passthrough: true
TrueHD capable receiver: true
Adjust display refresh rate: Off
Sync playback to display: false
Disable stereoscopic 3D mode when playback ended: true
Playback mode of stereoscopic 3D videos: Ask me
Display 4:3 videos as: Normal
Enable HQ scalers for scaling above: 20
Allow hardware acceleration with DRM PRIME: true
Accelerate MPEG2: Always
Accelerate MPEG4: HD and up
Accelerate h264: Always
Force 422 colour subsampling: false
Force RGB output: false
Use limited colour range (16-235): true
Lock HDMI HPD: false
GUI Resolution: 1280x720 @ 59.94p

3.7 was installed a few years back (it is an old receiver from around 2010/2011).

Setting the “Number of channels” to 2.0 => No luck.

set it to 7.1 NOT 2.0

OSMC is already sending the right format:

2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Output Device : AML-MESONAUDIO
2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Sample Rate   : 192000
2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Sample Format : AE_FMT_S16NE
2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Channel Count : 8
2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Channel Layout: RAW, RAW, RAW, RAW, RAW, RAW, RAW, RAW
2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Frames        : 4096
2021-11-07 02:37:10.907 T:2661    DEBUG <general>:   Frame Size    : 16

It’s just possible the tweaks which come to 19.3 may solve the problem, but I can’t guarantee OSMC will release 19.3 before Black Friday. Don’t hold back on a new receiver :stuck_out_tongue:

Same. That receiver schould do the down mixing for less channel. That works with dts.

hope you mean 3.70 ?

It was 3.70.

My new receiver arrived (Marantz 5015DAB) and the problem is gone. So it was the receiver.