OSMC Vero 4K External WIFI dongle

#1

Hi,

I have a TP-LINK Archer T4U v3 which I would like to work with my Vero 4k.

Firstly is this compatible? I plugged it in and it’s still using the on board card.

Secondly (if compatible) how do I get it to work?

Any support on this from the community would be greatly appreciated.

#2

What chipset does it use?

#3

I think RTL8822BU

#4

That isn’t supported at this time.
It might be supported when we move to Linux 4.9

Sam

#5

Thanks for confirming, would you mind letting me know which chipset are supported please?
Or a recommendation for a compatible decent external wi-fi adapter (with an antenna) so I get better signal strength and hence performance.

Thanks for prompt response Sam.

#6

Currently, RTL8812AU is the only out of tree module we are supporting.
The internal adapter should be good enough for 4K; provided that you are using 5Ghz and not 2.4Ghz.

#7

So if I bought an USB card with that chipset (https://www.amazon.co.uk/CSL-SuperSpeed-Wireless-detachable-frequency/dp/B015Z8EWGY/) and plug it in do I need to disable on board adapter by command line (SSH) or something?

The internal adapter is connected via 5GHz to my router however the device is barely in range so the ‘connected’ speed drops right down / is abit flakey. It worked great when the device was nearer to the router!
So I figure I get a USB device with an external antenna.

#8

It should just work; but that’s assuming it is as advertised.

Sam

#9

Well I’ll give it a try and post back with the results should anyone else be interested in the future.

Thanks again.

#10

I also found out that the TP-LINK Archer T4U v2 - https://wikidevi.com/wiki/TP-LINK_Archer_T4U_v2
has the RTL8812AU chipset.

#11

So the the wireless adapter below (with this chipset - RTL8812AU)

Is recognised.

However…
Whenever I try connect to a network the UI (mistakenly connects using the on-board adapter (wlan1) when I’ve selected wlan0.
I’ve tried to disable the onboard adapter via command line but with no luck.

I tried;
ip link

sudo ip link set dev wlan1 down

Does anyone have any ideas?

#12

So I managed to connect to a network using the USB Dongle by doing:

@sam_nazarko - I think there is some issue with the OSMC addon connecting to an external adapter, perhaps it wasn’t designed to do this? Maybe worth checking out if you have time and then adding to the backlog?

#13

You will need to connect manually via ConnMan. We only support managing one WiFi interface at a time.

Sam

#14

If you want to disable the internal WiFi adapter, run this command:

echo "blacklist dhd" | sudo tee /etc/modprobe.d/blacklist-dhd.conf

and then reboot.