OSMC Vero can't output 60Hz through Denon AVR

Hi Everyone!

One last remaining problem I have with the Vero 4K+:

If I set the refresh rate to 60 Hz (or more importantly when I start a 60Hz video) it works for some seconds/minutes then randomly lines appear in the video (like in an analogue signal some interference) and also sometimes it can be seen on 50 Hz.
If I connect the Vero 4K+ to the TV directly this doesn’t seem to be an issue. Only if I connect it through my Denon AVR-X3400H.

But I used an RPi before with Kodi and there I don’t had this issue (with and without the AVR), just Vero has this problem. Also other sources plugged into the AVR works normally.

I have also tried different (not “premium”, just standard, but certified) HDMI cables, but all had this issue…

Anyone any clue what can cause this? For me it looks like the Vero sends signals at this refresh rate little bit differently, that causes this lines/flickering.

Turn on debug logging, reboot twice, play some video until the issue happens, then upload a log, paste the link in this thread.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks, I will upload a log soon. However the issue happens not just when playing a video, but also in the menus. I will try to make a pic of the TV when this happens and how it looks.

The logs should let us see what your TV and AVR are advertising as supported.

This is expected when setting GUI to 4k60hz the signal is the same as when playing a video.

Yes I know and I’m changing the refresh rate there just to test this. I wouldn’t mind using the menu in 24fps only…
Also it is just 1080p60Hz, I don’t have a 4K TV yet, just to clarify this.

Here is my log:
http://paste.osmc.tv/kaconijuhu

I suggest you turn off force RGB and re-boot.

I will try thanks!
Can I change this through Kodi menu?

Settings->system->video. You may have to turn on expert mode (bottom left).

Turned itt off, now its even worse. Now these lines also appear on 50Hz and sometimes the screen is black. Then after some minutes it’s back to normal…

Try going into the settings of your AVR and for the Vero input turn off video conversion, i/p scaler, etc.

That was turned off before. After turning the ip scaler on, the 60Hz output became a little bit more stable. Now after turning the RGB force mode off, it doesn’t matter if I change these settings…

I didn’t mean just the i/p scaler. I meant to turn everything off in the Denon that is modifying the signal between the Vero and the TV.

I was a little bit unclear. Everything was turned off (and now also turned off). Basically if you didn’t use the scaler, most functions which can modify the output is already unavailable…

Are all the HDMI cables 2.0? As that is a requirement for 60hz. I know the HDMI cable that comes with vero 4k is 2.0. But i am thinking the other hdmi you are using might not be.

Also its better to set the option to set the refresh rate based no the video file because there are not many 60hz video files anyway. Well that i have come across.

I think the hobbit was the only film shot in higher refresh rate.

The option to automatically change the resolution and refresh rate based on the video file works best, because if you set it to 4k manually, it will automatically change back to 1080p. Which is annoying. So that option will auto change to 4k when you play 4k content and it works well.

I will check this. Maybe one of the cables is not 2.0. However with my RPi it worked before correctly, with the same cables/setup.

I don’t want to manually set refresh rate/resolution, I have set up Kodi so it would match the refresh rate/resolution upon when starting a video. However there are some older TV shows which comes in 60Hz. This is where I found out this problem. I’m just using the menu refresh rate to quickly check the status…

Interesting. What older TV shows come in 4k 60hz? Maybe cartoons?

I can confirm that vero 4k works fine at 60hz so it is definitely not the vero. I ran it through a yamaha 679 as well no issues at 4k 60hz. Just kept resetting back to 1080p (which is the TV apparently) so left it at 1080p when idle and use the option now to set it based on the video refresh rate.

At least some Denon AVRs, by default, limit themselves to HDMI 1.2. You need to set 4K Signal Format to Enhanced to have the full bandwidth of HDMI 2.0.

It seems to me this is unlikely to be a cabling issue except if there is a bad connection in one of the hdmi plugs/sockets. Have you tried different inputs on the AVR and TV?

Try updating to the latest version on OSMC.

Sorry, I didn’t had much time to watch movies until now, so the issue got forgotten also. But I did some tests now to have a deeper look into this…

First, I want to rephrase my inital question:
The inital title was wrong, this issue is not about 4K 60Hz, it is about 60Hz in general through Denon AVR. Before the title said “OSMC Vero 4K can’t output…”, where 4K was there for indication that I have a new OSMC Vero 4K+. However I don’t even have 4K screen, only a 1080p Panasonic TV (but it’s true that the Denon can output 4K, but I think this doesn’t matter here, because it knows the output device is only a 1080p device). Sorry for this, I have corrected the title.

So what I have tried so far:

  • Connecting the OSMC to different HDMI ports on the AVR (somewhere I read that physically closer HDMI inputs works better), but that didn’t helped, same “vibrating, streaked” output.
  • Installing OSMC on a RPi (where I used before), connecting that RPi to AVR ports, setting 60Hz and it worked perfectly.
  • Changing cables between OSMC and AVR and also between TV and AVR, same issue…
  • Upgrading OSMC to the newest version on the Vero 4K+, still the same issue (however what is interesting that after setting for example the GUI to 60Hz it works good until 1-2 minutes and just after that it starts vibrating and giving these “streaked” output or sometimes the output is totally gone).
  • Using different output device (another TV), same problem…
  • However (which I said earlier) when connecting OSMC directly to the TV, it works good even on 60Hz.
  • Turned i/p scaler ON/OFF in Denon settings (and played with other video output “alternator” setting). Usually this is turned off, but tried turning it on, but same occurs.
  • Turned force RGB ON/OFF in Kodi settings. Same issue…

Also I have for example a Google Chromecast connected to the AVR, which always outputs 60Hz image, and never had any problem with this before.

My conclusion is:
The OSMC works great without the AVR, but also an RPi works great with the AVR also, so I wouldn’t say that this is a hardware issue. It seems like the Vero outputs 60Hz image a little bit differently (I mean it differs in some way a little) what the AVR can’t tolerate.

If anyone has any advice for additional testing this or some solution I will be glad if this can be sorted out, really drives me nuts, because in overall I really like this device.
Tagging @sam_nazarko here, maybe he has some additional advice regarding these “tests”.
The config is the same, so it should be the same like this:

http://paste.osmc.tv/kaconijuhu

Thanks for everyone!