OSMC Vero V Review

I’d bet The Lord of the Rings would give you trouble too.

The full sync process ran last night. Here’s the results:

17m 23s - Vero 4K+ Mezzmo to Kodi sync 21k items
12m 39s - Vero V Mezzmo to Kodi sync 21k items

This is a 27% overall improvement in speed. For comparison purposes here are a few other platforms doing the same sync process:

51m 20s - Raspberry Pi 4
3 m 48s - Intel NUC 8i7BEH
7m 57s - Kodi on a Windows PC

The Raspberry Pi 4 suffers from a slow internal storage system since it is writing to the SD card.

Some preliminary feedback. I’m confident the V is better than the 4 for native interlaced content. I have only looked at blu-ray classic Dr Who so far, no pure SD testing. I always found the 4 to be inferior to my Panny disc players, the V is (to my eyes) a clear step up over the 4, and at least matches the Panny sources, if not a pinch better. I tried to get some screenshots but they didn’t show the difference very well, but the overall in-motion playback is for me improved.

No change that I can see for progessive content that is authored as 50i. With auto deinterlacing the V is failing the 25p output test for h264 and VC-1. Of course with VC-1 we can disable deinterlacing and I get a good 25p output when I whitelist that mode. I can’t achieve that with h264, so for now I’ll stick with other platforms for my 50i progressive h264 files as they can output clean frames with a bump in resolution as a result.

Something I noticed as a complete surprise: rendering of forced subtitles in HDR mkv’s to an HDR display is correct with the V, even though it’s still wrong with the 4 (and the Shield last time I looked). Here are shots from Avengers Assemble, these photos are a bit over-exposed but with the 4 I get mid grey subtitles, the second shot from the V the subs are white and match what I get from disc. I’m very pleased with this as on some titles (e.g. Captain America Civil War) the forced subs are far too dark on the 4, but on the V they are just right.

I’ll check the rendering of forced subs in HDR-to-SDR at the weekend.

Yes, OSD is handled in a separate video pipeline now (see the specs). On vero 4, sRGB images had to be converted to HDR for mixing with the video, which was … problematic.

1 Like

Does this also fix the subtitles on The Godfather (in 4K) which come out grey rather than gold on the Vero 4K? And what about the “subtitles coming up across more than one frame” issue?

see: Subtitles rendering across multiple frames - #46 by tanio99

That issue exists on both models 4k/4k+ and the V. I’ve tried some workarounds but tbh, today I don’t have any real solution.

I can’t say the difference in the sub colour is any more than the difference in colour rendering generally.
I wouldn’t call either of them ‘gold’ on my Panny LED.

Whom can i message that it will get fixed ?

No one. The person who would be able to figure it out is tanio99 and it hasn’t remained unfixed due to a lack or trying or desire (at least on OSMC’s end). It is more of a ‘some nuts are easier to crack than others’ type of situation.

Has anyone tried accessing Netflix, Disney Plus, Prime Video, etc. on the Vero V yet? I’m interested in what the resolution limits are compared to the Vero 4K.

just took a look at these test clips. The 480i_60 mpeg2 clip is terrible with hardware decoding, a very nasty shimmer to it that is gone when switching to software decoding.

the 1080i/60 VC-1 is interesting. With hardware playback, about 2 seconds in the output switches to 24p, picking up the 3:2 pulldown? Playback is very clean. Software playback sticks at 60 Hz.

Does anyone have similar test clip for 1080i h264? I feel sure the native interlaced scenes in my classic Dr Who blurays have more detail on the V than with the 4K.

I played a DVD rip with 3:2 pulldown and I think it’s equally poor on the V and the 4K.

1 Like

Not precisely, although some of the other clips I posted (the bits from Sherlock, Peaky Blinders and Luther) are 1080i/50 h.264. The Sherlock clip is probably the easiest to analyse visually.

Those wedge patterns come from an old Spears and Munsil calibration disc, so if anyone has a more recent version of such a disc, that might have h.264 equivalents.

If you haven’t already, also check out the Timeflight clip and compare hardware and software decoding - that’s a good one to test for whether it’s correctly applying diagonal filtering when in field-interlaced mode. (I’m guessing not).

Just got around to looking at the Sherlock clip, comparing the Vero V vs an old Pi running August OSMC. On the V Mycroft’s suit has obvious moire. On default settings it’s there on the Pi but with the Pi you can have hardware acceleration and disable deinterlacing, and when we do that the moire in Mycroft’s suit is gone, overall detail level is much improved. Would be great if this could addressed in some way, at present I’m only using the V in my main system for 24p and some 50i h264 content that is fully interlaced. For everything else I’m still using a Pi or the Infuse/ATV combo.

Heartily agree! Give me a shout if you have a chance to test my “Timeflight” clip.

Might want to keep an eye on this thread, btw:

well, I wouldn’t normally watch anything from Timeflight, but I have to give you credit, this is a good test clip.

Given previous comments, no surprises that with the V there are nasty jaggies on the Tardis console with hardware acceleration (I imagine there are as well with the 4K but I did not test). Switching to software playback fixes this, and if it weren’t for the occasional stutter, I’d consider disabling hardware acceleration for MPEG2.

I then played the clip on my OSMC Pi 3B, and I was impressed. Of course the Pi 3B has to use hardware acceleration, and the obvious jaggies with the Vero were pretty much absent as far as I could tell. On the basis of that one clip (yes, Timeflight!) I’m going to look again at putting Pi’s back in to service given the amount of MPEG2 in my collection, pending a fix for the Vero.


Heh, thanks. :slight_smile:

Yes. Sadly the Vero 4K was once capable of doing rather good diagonal filtering in hardware, but this got broken with the move from the 3.14 to 4.9 kernel, and hasn’t been fixed since. If you’ve got a spare Vero 4K (and enough HDMI ports) you could try installing the last Kodi v18.9 release on it (which was also the last with the 3.14 kernel) and using that as your MPEG2 playback device (with hardware decoding enabled); it used to look very good. Hardware cadence detection was also better on DVD remuxes than it is now. 1080i wasn’t much better than now, but the moiré patterns from cadence detection errors were a little less obvious - the diagonal filtering meant they were more blurry and less blocky. Interlaced VC-1 playback is better with a modern image, though. (And of course the Kodi 18.9 install doesn’t support 3D and HDR playback wasn’t as good).

Hi. Trying to do this following old 4k instructions but set up a bit different as it’s already part of an activity. I opened ms media player on app and then bluetooth pairing on myosmc and I’m not getting anything. Is this the process you followed ? Ta

@ac16161 You’ve been extremely helpful already :slight_smile: but if you happen to have some more time to spare, could you have a go at running my “Planet Earth” test clip? (As noted when I first posted it, that one is designed to check for stuttery playback when outputting a 25fps video at 50Hz).

can anyone point me to a link for last V4K image on the 3.14 kernel? The main download page only has 2023 releases that I could see. Curious to see how much of an improvement it is for interlaced MPEG2.

I didn’t notice any obvious stutter, but it’s a very short clip and my eyes may not be tuned in to the issues you’ve picked up.