OSMC version 2015.07-1 seek in video strange behaviour

I recently updated OSMC on my Pi to ver. 2015.07-1. But now seeking in video (i.e. pressing arrow key left or right) has changed. Instead of skipping 30 seconds it reacts a bit flimsy. I seems like the ‘seek 30 sec. forward’ feature has been changed to ‘fast forward’, that is: you have to hold down arrow key left or right to speed up playback instead of being able to skip half a minute.

How can I get the “skip” function back?

[edit] Wait a minute: it’s not a bug it’s a feature. Go to: “System > Video > Playback” and choose ‘Skip steps’. In that dialog window mark the desired steps yellow and disable unwanted steps (i.e. +10 sec. and -10 sec.) by making them white. Press OK. Then set the ‘Skip delay’ to ‘None’.

Info here: http://kodi.wiki/view/Skip_steps

@popcornmix , the behavior the OP states is not what is described on the link you posted. The OP said you highlight the step you want (make it yellow) then click ok, meaning you get ONE choice, where is the info at the link you posted states you have ALL of those choices and the selection is made based on how many times you hit the skip button (as long as the delay hasn’t transpired between button presses). I’ve always had this annoying “feature” which skips to the end of my video anytime i try to use the skip button (forward or backward). Any ideas?

Are you using confluence skin? The layout/colours may be different in a different skin.

Are you saying it skips to end of video when you press right once?
Post a photo of the skip settings screen and a debug log.

Using default OSMC skin. My skip times settings are not selectable/editable via the gui. They will highlight in yellow as i scroll with the up/down buttons, but there is no “selecting” any one of them. So the OPs instructions don’t apply to me. On the Kodi wiki page you pointed me to, they talk about modifying a text file to change the skip/seek times. Looks like that more accurately applies to me.

Yes, it seems to skip to the end with one button press, but I only say that because the video stops playing and Kodi returns to the menu where i can select the video, a recorded tv episode (Designated Survivor) in this particular case. When i select the video again, it doesn’t ask me to resume, it just starts playing from the beginning.

If i scroll down, there are more skip choices, that is, this is the “top” choices that will display. The transition from negative numbers to positive numbers is -10 sec and 10 sec. So one skip forward press should be 10 sec while one skip backwards press should be -10 sec.

The log file is here http://paste.osmc.io/mawatepaci . I couldn’t really make much sense of the log file. The string “Designated Survivor” shows up like 74 times and the time stamp on each line seem to be out of order. But i’ll let you guys (the experts) interpret the log file. Just let me know if i need to enable any additional logging functions and repost a log file.

Can you advise exactly what remote you are using and exactly what button you are pressing?

I think this may be a bug in the skin where the enabled options are not highlighted.
Try switching to confluence where the settings will match the wiki.
If all is working you can switch back to OSMC skin.


We have abandoned the old skin now, and we are focusing on a new design.

the file is guisettings.xml
Run this command and post your output cat .kodi/userdata/guisettings.xml | grep seek

@fzinken, here’s the output of the cat command

This is not showing up correctly in the forum… let me try to fix

ok, here it is
<seekdelay default="true">750</seekdelay> <seeksteps default="true">-60,-30,-10,10,30,60</seeksteps> <seekdelay default="true">750</seekdelay> <seeksteps>-600,-300,-180,-60,-30,-10,30,180,300,600</seeksteps>

Thanks for the poointer. I’ve never changed skins before so i’ll have to do some searching on this topic before i attempt. I’ll post back and let you guys know what happens.

@sam_nazarko, i was kinda fond of the old skin. Any idea when the new skin will be available? Will it automatically take effect with an auto update?

The new skin is already available for testing. More at We've been working on a new look and feel for OSMC - OSMC.

When Kodi Krypton is released, we will deliver the new skin via an update.


Use the preformatted text button </> on the menu than your text is better readable
But seems you already have changed the settings. You config means a single right click now jumps 30 seconds.
Default looks like this

        <seekdelay default="true">750</seekdelay>
        <seeksteps default="true">-60,-30,-10,10,30,60</seeksteps>
        <seekdelay default="true">750</seekdelay>
        <seeksteps default="true">-600,-300,-180,-60,-30,-10,10,30,60,180,300,600</seeksteps>

@fzinken, i haven’t intentionally changed these settings. I fixed the text using the preformatted text char (see previous post). Mine is missing the 'default=“true” in the last line. Nonetheless, it doesn’t skip 30 seconds, it skips to the end.

I’ll still try changing the skin though and see if that helps.

@sam_nazarko, thanks for the pointer to the early release

It is missing the “default” because it is not anymore default as you don’t have the 10 second setting if you compare the two lines.
But anyhow if it jumps to the end must be another reason

Ok, yes the skin is “messing up” the perception of changing the settings, but… if i highlight a time (old skin) and hit enter on the keyboard, i hear the swipe sound and my configuration indeed changes. That’s how the 10 sec came to be missing from the config file (i indeed changed it, inadvertently). So i removed all but the -60, -30, -10, 10, 30, 60 second settings and i get different behavior. I also get different behavior now when using the keyboard/mouse (it’s a keyboard with a built in mouse pad and buttons) versus the remote.

When using the keyboard/mouse, i’m using the mouse pointer to highlight the skip “buttons” on the bottom of the screen and then left clicking. When doing this, the video still stops playing, but, no longer does the video want to start from the beginning when i select it again. It starts from basically where it left off (not +/- 10 sec).

Also, I have failed to answer @ActionA 's question regarding my remote. It’s a Rosewill RHRC-11002 IR remote (with USB dongle), with a big green button (i think these are called MCE remotes). When using the remote, the skip back button does NOT stop the video, but does bring me back to the screen where all my videos (recorded tv shows) are displayed. But the video keeps playing in the background. When i use the skip forward button, the video stops, i get back to the screen with all the videos and when i select the same video, it starts from where it left off, maybe a few (~3) seconds ahead.

So, let’s not worry about the remote at this point as it seems it’s a mapping issue. I’ve spent hours and HOURS trying to figure out button mapping, but to no avail. So for now, i will only use the keyboard/mouse when debugging this issue, which still exists even when using the keyboard/mouse.

Try using the right and left arrow keys on the remote, not the skip forward/back buttons

Yes, this is what the various skip times refer to.

these work as intended. That is, they “fast forward” and “rewind” 2x, 4x, 8x, etc… depending on how many times you press the button (no delay concept with this function)

The arrow keys? They should NOT work a FF/RW They should be skip steps