OSMC Wakes up my TV Via HDMI

I am positive that this must have come up, but can’t find any answers. I am running Pi2 with OSMC and connected the Pi to my Samsung TV Via HDMI with all of the benefits of being able to use the remote control.
At irregular intervals I find the TV turned on. If I turn the Pi off or disconnect it this behaviour stops, so it is the Pi that is the Culprit.
These symptoms have been more or less frequent for around a year now.
How do I get the Pi to stop waking up my TV unbidden?

What’s the manufacturer of your tv?

Are you sure no solutions that you can see in the threads that come up with a simple search help?

Samsung TV

It’s a known problem with Samsung TVs.

Go to System -> Settings -> System -> Input Devices -> Peripherals -> CEC adapter and disable “set Kodi as active source when start” or a similar setting.

Sorry for not replying sooner.
I think the setting you are referring to is
“Switch Source to this device on startup.”