OSMC wifi dongle conection problem

I have received my new OSMC wifi dongle.

I have make the wifi configuration and the router assigns IP, etc., but the Mac Adres and internet are continuously in a loop busy/not connected.

Any ideas??




sudo mv /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mt7610u_sta.dat

And reboot.

Thanks Tom.

If dmesg shows usb drops then check your PSU. This dongle uses quite a bit of power


Done and solved!!!

It’s connected with a powered USB Hub so power it’s not a issue.


Another question.

The ac 5G top speed is 150mb???

I see in the OSMC store and in Mediatek that the dongle speed is 433mbps but my router reports 150mps. ¿¿??


Depends on a number factors:

  • Distance from router
  • Signal Quality
  • have you got 2 separate ssids for 2.4 & 5?

Whats the make & model of the router?

Thanks Tom.

i swapped a Edimax AC600 for the OSMC. The Edimax connects at 433mbps but the problems with the support made me decide to change for the OSMC.

The router is an Asus RT-AC68U and all things about distance, signal and ssid’s are ok.


The reason the vero4k by default has the dat file as mt7610u_sta.template.dat, is so a lot of the config is auto setup so the best connection is achieved. So with this in mind you have a couple choices:

Now that a stable connection has been achieved, you could try reverting and see if the auto setup now works:

sudo mv /lib/firmware/mt7610u_sta.dat /lib/firmware/mt7610u_sta.template.dat

And reboot.


Manual editing the mt7610u_sta.dat , changing CountryCode & WirelessMode should be sufficient; make a backup first. I believe these are the correct possible values for both:

{AG, AR, AW, AU, AT, BS, BB, BM, BR, BE, BG, CA, KY, CL, CN, CO, CR, CY, CZ, DK, DO, EC, SV, FI, FR, DE, GR, }
{GU, GT, HT, HN, HK, HU, IS, IN, ID, E, IL, IT, JP, JO, LV, LI, LT, LU, MY, MT, MA, MX, NL, NZ, NO, PE, PT, }
{PL, RO, RU, SA, CS, SG, SK, SI, ZA, KR, ES, SE, CH, TW, TR, GB, UA,  

{0: legacy 11b/g mixed}
{1: legacy 11b only}
{2: legacy 11a only}
{3: legacy 11a/b/g mixed}
{4: legacy 11g only}
{5: 11a/b/g/n mixed}
{6: 11n only}
{7: 11g/n mixed}
{8: 11a/n mixed}
{9: 11b/g/n mixed}
{10: 11a/g/n mixed}
{11: ??} 
{12: ??} 
{13: g/n/ac in 2.4GHz and 5GHz}

Thanks Tom.

Revert the file has solved the problem. Now connection is 433mbps.


1 Like

The speed issue is solved but i have a lot of drops that make the dongle unusable.

As i said is connected with a powered usb hub.

Try this

This has solved the issue. Now is stable and top speed.