Wifi is disconnects after few minutes of work

After latest update I see very huge instability in Wifi, I’m using RPI2 with TP-Link Archer 1200AC adapter, which was working fine till the latest update, never experienced disconnects.
The RPI2 locate 5 meters from the router, no wals, signal strength is high. After reboot it working for 10 minutes and then in the network information I see, MAC address - Busy, and it stops to work. Need to do a reboot, or plug-off plug-in wifi adapter again.
Here the logs : http://paste.osmc.io/iwisozalot.vhdl


Are the logs been produced after the wifi fails?

I created the file after it stopped to work, correct.

Nothing really obvious. The only thing I see is that there are some wlan0 entries when backgorund scanning kicks in.
So if you are connected via SSH can you reconnect after a minute or so without restart?

Not really, I need to restart or to pull off the wifi adapter and the plug it in, after that it starting to work for a few minutes.

Not much ideas I have especially if it worked before the update. What you could try:

  1. add BackgroundScanning=false to /etc/connman.conf and restart
  2. try a different power supply
  3. if both of that fails install a June Image on a second SD card and check if that is stable

Replaced power supply (to one from RPI3, and added BackgroundScanning=false).
Hope it will help.

Well, it’s stable now, don’t know what helped, a new power supply or BackgroundScanning=false

Would you mind to change BackgroundScanning to true for testing?

Tried, after 10 minutes , more or less disconnected.

Thanks, that indicates the relation to background scanning being the culprit

Seems so, so is this related to hardware or software ?

Both, means that the driver of your stick doesn’t support background scanning properly

But, it was stable till the latest update.

Well not sure if you specific driver was updated during the last update.
Other than that while there were some changes to connman (in the first backup actually background scanning by default) the second update (that was issued before you upgraded) reversed that so that basically for you there shouldn’t have been a change

No changes for the driver. Issue is somewhere else.

That’s a bit vague though: not sure what that means? It either is or isn’t disconnected

More or less was for the time period when it’s disconnects. :relaxed:

What can be issue here, if BackgroundScanning=false solved the issue ?
Nothing changed , just latest update.