Problem with Wireless Dongle from OSMC Store

Just got my new wireless adapter today and plugged it into my Raspberry Pi. It was recognized immediately, but it only finds ONE SSID to connect to, even though I have several in my house, let alone the one’s outside my house that can be scanned.

I connect to the 5G connection from my router and I only get 5.39 Mbit/s Download and 3.85 Mbit/s Upload. When I use an ethernet connection via Power Over Ethernet connection my download speeds were 64.58 Mbit/s and my upload speeds were 10.67 Mbit/s.

My laptop can get 160Mbit/s when connected to my 5G access point using my laptop’s internal wireless adapter.

In addition, when I reboot my Raspberry Pi, the wireless dongle is NOT recognized. I have to go into the OSMC settings and re-enable the wireless adapter. Can you direct me to a resolution to the issues above?

I have a Raspberry Pi 2 with OSMC loaded.

Could be a channel issue based on the country setting. You might want to try to install cdra and set your country manually.

Generally in this cases I suggest to install wavemon to monitor the signal strength as one problem is that OSMC switches to scanning if the signal falls below a certain level.

You also can try to disable background scanning, see this thread

Could be a power issue. Do you have other USB devices connected? What powersupply are you using?

1 Like

I am using a powered USB HUB that has worked just fine up to this point. I was using an Edimax wireless dongle previously that could only connect to 2.4ghz channels and this prompted me to look into the POE option, which improved things drastically. I was hoping to increase things further with this 5g adapter.

I will research the other suggestions tomorrow before responding back. Thanks for the suggestions.

Indeed. A lot more power is needed for an 802.11ac dongle

I have a wireless keyboard dongle plugged into the hub also. I bought the hub and the power supply couple of years ago from the adafruit store.

I disconnected the dongle from the USB Hub and connected it directly to the Pi and the speeds improved. However, they were not as good as the POE connection. So I will keep this dongle and use it for another Pi project I have in mind, but will continue to use the POE connection. Thanks for those who responded.

Also when I connected the dongle directly to the Pi, I was able to see other SSID’s that were not shown when it was connected to the USB Hub. However, I still only was able to scan One SSID from my router. Is this dongle designed to only show 5G connections? If this is the case, then it is working as designed.

No – it will show you 2.4 and 5G, but you may need to manually change the channel.


Sam how do I “manually” change the channel? When the dongle is plugged in it should show all available connections regardless to 2.4 or 5G… YES/NO?

Yes — when configured properly you will see all networks.

Search for mt7610u_sta.dat


Sam the reason I bought this wireless dongle is because I thought it was plug and play with the Raspberry Pi and OSMC. Now it appears that I will need download and configure several files to get this thing to work on both networks. I had to jump through all kinds of shenanigans to get the Edimax up and running and was anticipating that this would be a walk in the park.



If you’ve recently received it you can of course return it.

The OSMC adapter is guaranteed to be supported and stay supported across future versions of OSMC however. Other adapters are not.

There is no need to download any files.

The necessary file is already included as a template on a recent version of OSMC. Manual configuration is only needed in a very small number of situations where OSMC cannot configure itself to the local

You should be getting good speeds on the 5Ghz spectrum. I would check that PSU. If it’s a couple of years ago, it may not be providing enough power. Simplest way is to try the OSMC dongle on a Windows PC in the same room.


@wussery this sounds a bit like a power issue if you see differences between it connected to the HUB or the Pi. Is it a powered Hub? Defiently may make sense to recheck your powersupply.

Other than that as mentioned by Sam in some situations the country/channel settings are wrongly auto detected. You basically have two options either set the country manually in mt7610u_sta.dat or you install crda to set the country. More than happy to help.
First to check which mt7610 files you have ls -lah /lib/firmware/mt7610u*
To set country first install crda sudo apt-get install crda and e.g. set country to US sudo iw reg set US

1 Like

Output from ls -lah /lib/firmware/mt7610u* is:

-rw-r–r-- 1 root root 1.3K May 1 2016 /lib/firmware/mt7610u_sta.dat
-rw-r–r-- 1 root root 1.3K Mar 5 2017 /lib/firmware/mt7610u_sta.template.dat

I’ve set the country code to US

Did you reboot and did it solve the visibility of the 5G network?

My download speeds on my Windows Laptop with the OSMC wireless dongle are comparable to the speeds that I’m getting with my internal wireless adapter. So there is no issue with the dongle, but must be with my Pi configuration or power to the Pi. As stated previously I removed the USB hub from the equation and plugged the dongle directly into the Pi. This setup gave me better speeds than when I was connected to the USB hub.

Not yet. I’ll try that now and report back.

After reboot my download speed is 8Mbps and my upload speed is 4.6Mbps. I should be getting about 140-150Mpbs with my 5G connection as I did on my laptop using the OSMC dongle in Windows 10.

So now you saw your 5G SSID and were able to connect to it?
Is the 8Mbps or and average? If it is heavy fluctuating there might be still an issue with background scanning.
Maybe first check signal quality with wavemon sudo apt-get install wavemon.

I was able to see the 5G connection when it was plugged in to the USB hub or directly into the Pi. What I couldn’t see was my 2.4ghz SSID nor all of the other SSID’s that I can’t connect to (my neighbors).

Oh sorry than I misunderstood you as most often people where missing the 5G networks.
So can you now also see the 2.4g or still not?